locutus call_user_func_array vulnerable to Remote Code Execution (RCE) due to Code Injection
CVE-2026-29091GHSA-fp25-p6mj-qqg6
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (locutus 3.0.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm locutus
- Affected
- <= 2.0.39
- Fixed in
- 3.0.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-fp25-p6mj-qqg6 lists affected ranges: npm locutus >=0 <3.0.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-fp25-p6mj-qqg6 lists affected ranges: npm locutus >=0 <=2.0.39
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.1 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2026-29091: 0.89% estimated exploitation activity in the next 30 days; percentile 59.43 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Details A Remote Code Execution (RCE) flaw was discovered in the locutus project (v2.0.39), specifically within the calluserfuncarray function implementation. The vulnerability allows an attacker to inject arbitrary JavaScript code into the application's runtime environment. This issue stems from an insecure implementation of the calluserfuncarray function (and its wrapper calluserfunc), which fails to properly validate all components of a callback array before passing them to eval(). ------ Technical Details The vulnerability is in the calluserfuncarray function in src/php/funchand/calluserfuncarray.js, between lines 31 and 35 of version 2.0.39. This function mimics PHP's dynamic function call feature and accepts a callback argument, which can be a string (function name) or an array (class and method name). The developers applied a regular expression check (validJSFunctionNamePattern) to the first array element (the class identifier), but not to the second element (the method…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-fp25-p6mj-qqg6
- Revision 1 · created ·
Published from osv record GHSA-fp25-p6mj-qqg6
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-29091 Advisory: locutus call_user_func_array vulnerable to Remote Code Execution (RCE) due to Code Injection IDs: CVE-2026-29091, GHSA-fp25-p6mj-qqg6 Record: https://patchnext.com/advisories/cve-2026-29091 (revision 2, source checked 26 Oct 2026, 12:43 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: locutus 3.0.0. A vendor fix does not mean a deployment is fixed. ## Affected components - npm locutus: affected <= 2.0.39; fixed in 3.0.0 ## Suggested inspection (read-only) - `npm ls locutus --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on locutus. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-fp25-p6mj-qqg6 (OSV record GHSA-fp25-p6mj-qqg6 lists affected ranges: npm locutus >=0 <3.0.0 (fixed)) - Verified: https://github.com/advisories/GHSA-fp25-p6mj-qqg6 (GitHub-reviewed advisory GHSA-fp25-p6mj-qqg6 lists affected ranges: npm locutus >=0 <=2.0.39) Commands are suggestions: review each one before running it.
Loading voting…