Skip to content

← Actionable
Critical, CVSS 9.0amended

Rucio has SQL Injection in FilterEngine PostgreSQL Query Builder via DID Search API

CVE-2026-29090GHSA-6j7p-qjhg-9947

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (rucio 40.1.1, 39.4.2, 38.5.5, 35.8.5), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI rucio

    Affected
    >= 1.30.0, < 35.8.5>= 36.0.0, < 38.5.5>= 39.0.0, < 39.4.2>= 40.0.0, < 40.1.1
    Fixed in
    35.8.5, 40.1.1, 39.4.2, 38.5.5

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
9.0 · CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H · score source
EPSS
  • CVE-2026-29090: 0.30% estimated exploitation activity in the next 30 days; percentile 22.91 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary A SQL injection vulnerability in FilterEngine.createpostgresquery allows any authenticated Rucio user to execute arbitrary SQL against the configured PostgreSQL metadata database through the DID search endpoint (GET /dids/<scope/dids/search). When the external metadata plugin postgresmeta is configured, attacker-controlled filter keys and values are interpolated directly into raw SQL statements via Python str.format. This enables full database compromise including data exfiltration, data modification, and potential remote code execution via COPY ... FROM PROGRAM. --- Details The vulnerability exists in lib/rucio/core/didmetaplugins/filterengine.py within the createpostgresquery() method (lines 408-484). This method builds raw SQL strings via Python .format() across 6 distinct injection points: filterengine.py:477 (string equality — default branch): filterengine.py:442 (wildcard/LIKE branch): filterengine.py:456 (boolean branch — value unquoted): filterengine.py:462 (numeric…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 4 · amended ·

    Amended from ghsa record GHSA-6j7p-qjhg-9947

  2. Revision 3 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 2 · amended ·

    Amended from osv record GHSA-6j7p-qjhg-9947

  4. Revision 1 · created ·

    Published from ghsa record GHSA-6j7p-qjhg-9947

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-29090

Advisory: Rucio has SQL Injection in FilterEngine PostgreSQL Query Builder via DID Search API
IDs: CVE-2026-29090, GHSA-6j7p-qjhg-9947
Record: https://patchnext.com/advisories/cve-2026-29090 (revision 4, source checked 26 Oct 2026, 13:46 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.0)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: rucio 40.1.1, 39.4.2, 38.5.5, 35.8.5. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI rucio: affected >= 1.30.0, < 35.8.5; >= 36.0.0, < 38.5.5; >= 39.0.0, < 39.4.2; >= 40.0.0, < 40.1.1; fixed in 35.8.5, 40.1.1, 39.4.2, 38.5.5

## Suggested inspection (read-only)
- `python -m pip show rucio`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on rucio.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-6j7p-qjhg-9947 (GitHub-reviewed advisory GHSA-6j7p-qjhg-9947 lists affected ranges: PyPI rucio >=1.30.0 =36.0.0 =39.0.0 =40.0.0 <40.1.1)
- Verified: https://osv.dev/vulnerability/GHSA-6j7p-qjhg-9947 (OSV record GHSA-6j7p-qjhg-9947 lists affected ranges: PyPI rucio >=1.30.0 =36.0.0 =39.0.0 =40.0.0 <40.1.1 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…