Skip to content

← Actionable
High, CVSS 7.5amended

@hono/node-server has authorization bypass for protected static paths via encoded slashes in Serve Static Middleware

CVE-2026-29087GHSA-wc8c-qw6v-h7f6

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@hono/node-server 1.19.10), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
EPSS
  • CVE-2026-29087: 0.36% estimated exploitation activity in the next 30 days; percentile 30.22 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary When using @hono/node-server's static file serving together with route-based middleware protections (e.g. protecting /admin/), inconsistent URL decoding can allow protected static resources to be accessed without authorization. In particular, paths containing encoded slashes (%2F) may be evaluated differently by routing/middleware matching versus static file path resolution, enabling a bypass where middleware does not run but the static file is still served. Details The routing layer and the node-server static handler normalize request paths differently. The router preserves %2F as a literal string when matching routes, while the static handler decodes %2F into / before resolving the filesystem path. Example request: - /admin%2Fsecret.html This may: - fail to match middleware intended for /admin/, but - still be resolved by the static handler as /admin/secret.html under the configured static root. This does not allow access outside the configured static root and is not a path…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-wc8c-qw6v-h7f6

  2. Revision 1 · created ·

    Published from osv record GHSA-wc8c-qw6v-h7f6

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-29087

Advisory: @hono/node-server has authorization bypass for protected static paths via encoded slashes in Serve Static Middleware
IDs: CVE-2026-29087, GHSA-wc8c-qw6v-h7f6
Record: https://patchnext.com/advisories/cve-2026-29087 (revision 2, source checked 26 Oct 2026, 12:43 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @hono/node-server 1.19.10. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @hono/node-server: affected < 1.19.10; fixed in 1.19.10

## Suggested inspection (read-only)
- `npm ls @hono/node-server --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @hono/node-server.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-wc8c-qw6v-h7f6 (OSV record GHSA-wc8c-qw6v-h7f6 lists affected ranges: npm @hono/node-server >=0 <1.19.10 (fixed))
- Verified: https://github.com/advisories/GHSA-wc8c-qw6v-h7f6 (GitHub-reviewed advisory GHSA-wc8c-qw6v-h7f6 lists affected ranges: npm @hono/node-server >=0 <1.19.10)

Commands are suggestions: review each one before running it.

Loading voting…