Skip to content

← Actionable
High, CVSS 7.5amended

SVGO DoS through entity expansion in DOCTYPE (Billion Laughs)

CVE-2026-29074GHSA-xpqw-6gx7-v673

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (svgo 4.0.1, 3.3.3, 2.8.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm svgo

    Affected
    >= 2.1.0, < 2.8.1>= 3.0.0, < 3.3.3>= 4.0.0, <= 4.0.0
    Fixed in
    2.8.1, 3.3.3, 4.0.1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2026-29074: 0.70% estimated exploitation activity in the next 30 days; percentile 53.30 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary SVGO accepts XML with custom entities, without guards against entity expansion or recursion. This can result in a small XML file (811 bytes) stalling the application and even crashing the Node.js process with JavaScript heap out of memory. Details The upstream XML parser (sax) doesn't interpret custom XML entities by default. We pattern matched custom XML entities from the DOCTYPE, inserting them into parser.ENTITIES, and enabled unparsedEntities. This gives us the desired behavior of supporting SVGs with entities declared in the DOCTYPE. However, entities can reference other entities, which can enable small SVGs to explode exponentially when we try to parse them. Proof of Concept Impact If SVGO is run on untrusted input (i.e., user uploaded to server-side application), then the untrusted SVG can effectively stall or crash the application with an SVG < 1 KB in size. It's unlikely to impact users who just use SVGO locally on their own SVGs or in build pipelines. Patches SVGO…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-xpqw-6gx7-v673

  2. Revision 1 · created ·

    Published from osv record GHSA-xpqw-6gx7-v673

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-29074

Advisory: SVGO DoS through entity expansion in DOCTYPE (Billion Laughs)
IDs: CVE-2026-29074, GHSA-xpqw-6gx7-v673
Record: https://patchnext.com/advisories/cve-2026-29074 (revision 2, source checked 26 Oct 2026, 12:43 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: svgo 4.0.1, 3.3.3, 2.8.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm svgo: affected >= 2.1.0, < 2.8.1; >= 3.0.0, < 3.3.3; >= 4.0.0, <= 4.0.0; fixed in 2.8.1, 3.3.3, 4.0.1

## Suggested inspection (read-only)
- `npm ls svgo --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on svgo.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-xpqw-6gx7-v673 (OSV record GHSA-xpqw-6gx7-v673 lists affected ranges: npm svgo >=2.1.0 =3.0.0 =4.0.0 <4.0.1 (fixed))
- Verified: https://github.com/advisories/GHSA-xpqw-6gx7-v673 (GitHub-reviewed advisory GHSA-xpqw-6gx7-v673 lists affected ranges: npm svgo >=2.1.0 =3.0.0 =4.0.0 <=4.0.0)

Commands are suggestions: review each one before running it.

Loading voting…