Skip to content

← Actionable
Critical, CVSS 9.8

WWBN AVideo is vulnerable to unauthenticated OS Command Injection via base64Url in objects/getImage.php

CVE-2026-29058GHSA-9j26-99jh-v26q

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (wwbn/avideo 7.0.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2026-29058: 8.94% estimated exploitation activity in the next 30 days; percentile 95.25 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact An unauthenticated attacker can execute arbitrary OS commands on the server by injecting shell command substitution into the base64Url GET parameter. This can lead to full server compromise, data exfiltration (e.g., configuration secrets, internal keys, credentials), and service disruption. Root Cause The base64Url parameter is Base64-decoded and then interpolated directly into a double-quoted ffmpeg shell command without proper shell escaping. The upstream validation uses FILTERVALIDATEURL, which validates URL syntax but does not prevent shell metacharacters / command substitution sequences from being interpreted by the shell. Affected Components objects/getImage.php objects/security.php Execution path via async command execution helper (shellexec/nohup) Patches Apply strict shell argument escaping (e.g., escapeshellarg()) to all user-supplied values before building any shell command, and avoid double-quoted interpolation of untrusted input. Prefer safer process execution…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-9j26-99jh-v26q

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-29058

Advisory: WWBN AVideo is vulnerable to unauthenticated OS Command Injection via base64Url in objects/getImage.php
IDs: CVE-2026-29058, GHSA-9j26-99jh-v26q
Record: https://patchnext.com/advisories/cve-2026-29058 (revision 1, source checked 26 Oct 2026, 14:38 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: wwbn/avideo 7.0.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist wwbn/avideo: affected < 7.0.0; fixed in 7.0.0

## Suggested inspection (read-only)
- Packagist wwbn/avideo: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on wwbn/avideo.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-9j26-99jh-v26q (GitHub-reviewed advisory GHSA-9j26-99jh-v26q lists affected ranges: Packagist wwbn/avideo >=0 <7.0.0)

Commands are suggestions: review each one before running it.

Loading voting…