Next.js: HTTP request smuggling in rewrites
CVE-2026-29057GHSA-ggv3-7p47-pfv8
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (next 16.1.7, 15.5.13), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm next
- Affected
- >= 16.0.0-beta.0, < 16.1.7>= 9.5.0, < 15.5.13
- Fixed in
- 15.5.13, 16.1.7
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-ggv3-7p47-pfv8 lists affected ranges: npm next >=16.0.0-beta.0 =9.5.0 <15.5.13 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-ggv3-7p47-pfv8 lists affected ranges: npm next >=16.0.0-beta.0 =9.5.0 <15.5.13
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 6.3 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2026-29057: 0.45% estimated exploitation activity in the next 30 days; percentile 39.41 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary When Next.js rewrites proxy traffic to an external backend, a crafted DELETE/OPTIONS request using Transfer-Encoding: chunked could trigger request boundary disagreement between the proxy and backend. This could allow request smuggling through rewritten routes. Impact An attacker could smuggle a second request to unintended backend routes (for example, internal/admin endpoints), bypassing assumptions that only the configured rewrite destination/path is reachable. This does not impact applications hosted on providers that handle rewrites at the CDN level, such as Vercel. Patches The vulnerability originated in an upstream library vendored by Next.js. It is fixed by updating that dependency’s behavior so content-length: 0 is added only when both content-length and transfer-encoding are absent, and transfer-encoding is no longer removed in that code path. Workarounds If upgrade is not immediately possible: - Block chunked DELETE/OPTIONS requests on rewritten routes at your…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-ggv3-7p47-pfv8
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-ggv3-7p47-pfv8
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-29057 Advisory: Next.js: HTTP request smuggling in rewrites IDs: CVE-2026-29057, GHSA-ggv3-7p47-pfv8 Record: https://patchnext.com/advisories/cve-2026-29057 (revision 3, source checked 26 Oct 2026, 12:46 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: next 16.1.7, 15.5.13. A vendor fix does not mean a deployment is fixed. ## Affected components - npm next: affected >= 16.0.0-beta.0, < 16.1.7; >= 9.5.0, < 15.5.13; fixed in 15.5.13, 16.1.7 ## Suggested inspection (read-only) - `npm ls next --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on next. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-ggv3-7p47-pfv8 (OSV record GHSA-ggv3-7p47-pfv8 lists affected ranges: npm next >=16.0.0-beta.0 =9.5.0 <15.5.13 (fixed)) - Verified: https://github.com/advisories/GHSA-ggv3-7p47-pfv8 (GitHub-reviewed advisory GHSA-ggv3-7p47-pfv8 lists affected ranges: npm next >=16.0.0-beta.0 =9.5.0 <15.5.13) Commands are suggestions: review each one before running it.
Loading voting…