Ghost Vulnerable to Remote Code Execution via Malicious Themes
CVE-2026-29053GHSA-cgc2-rcrh-qr5x
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (ghost 6.19.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm ghost
- Affected
- >= 0.7.2, <= 6.19.0
- Fixed in
- 6.19.1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-cgc2-rcrh-qr5x lists affected ranges: npm ghost >=0.7.2 <6.19.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-cgc2-rcrh-qr5x lists affected ranges: npm ghost >=0.7.2 <=6.19.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.6 · CVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:C/C:H/I:H/A:H
- EPSS
- CVE-2026-29053: 4.90% estimated exploitation activity in the next 30 days; percentile 92.11 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact Specifically crafted malicious themes can execute arbitrary code on the server running Ghost. Vulnerable Versions This vulnerability is present in Ghost v0.7.2 to v6.19.0. Patches v6.19.1 contains a fix for this issue. Workarounds Ghost generally recommends users refrain from installing untrusted themes. If a malicious theme has already been installed, it is recommended to uninstall the theme and then inspect it to understand its impact, which will be attack-specific. References Ghost thanks Cristian-Alexandru Staicu at Endor Labs for disclosing this vulnerability responsibly. For more information If there are any questions or comments about this advisory, email Ghost at security@ghost.org.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-cgc2-rcrh-qr5x
- Revision 1 · created ·
Published from osv record GHSA-cgc2-rcrh-qr5x
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-29053 Advisory: Ghost Vulnerable to Remote Code Execution via Malicious Themes IDs: CVE-2026-29053, GHSA-cgc2-rcrh-qr5x Record: https://patchnext.com/advisories/cve-2026-29053 (revision 2, source checked 26 Oct 2026, 12:42 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.6) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: ghost 6.19.1. A vendor fix does not mean a deployment is fixed. ## Affected components - npm ghost: affected >= 0.7.2, <= 6.19.0; fixed in 6.19.1 ## Suggested inspection (read-only) - `npm ls ghost --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on ghost. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-cgc2-rcrh-qr5x (OSV record GHSA-cgc2-rcrh-qr5x lists affected ranges: npm ghost >=0.7.2 <6.19.1 (fixed)) - Verified: https://github.com/advisories/GHSA-cgc2-rcrh-qr5x (GitHub-reviewed advisory GHSA-cgc2-rcrh-qr5x lists affected ranges: npm ghost >=0.7.2 <=6.19.0) Commands are suggestions: review each one before running it.
Loading voting…