Skip to content

← Actionable
Medium, CVSS 6.1

melange has Path Traversal When Resolving External Pipelines via Unvalidated pipeline[].uses

CVE-2026-29050GHSA-98f2-w9h9-7fp9

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (chainguard.dev/melange 0.43.4), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.1 · CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:L/A:N
EPSS
  • CVE-2026-29050: 0.14% estimated exploitation activity in the next 30 days; percentile 3.35 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact An attacker who can influence a melange configuration file — for example through pull-request-driven CI or build-as-a-service scenarios — could set pipeline[].uses to a value containing ../ sequences or an absolute path. The (Compiled).compilePipeline function in pkg/build/compile.go passed uses directly to filepath.Join(pipelineDir, uses + ".yaml") without validating the value, so the resolved path could escape each --pipeline-dir and read an arbitrary YAML-parseable file visible to the melange process. Because the loaded file is subsequently interpreted as a melange pipeline and its runs: block is executed via /bin/sh -c in the build sandbox, this additionally allowed shell commands sourced from an out-of-tree file to run during the build, bypassing the review boundary that normally covers the in-tree pipeline definition. Patches Fixed in melange v0.43.4 via commit 5829ca4. The fix rejects uses values that are absolute paths or contain .., and verifies (via filepath.Rel…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-98f2-w9h9-7fp9

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-29050

Advisory: melange has Path Traversal When Resolving External Pipelines via Unvalidated pipeline[].uses
IDs: CVE-2026-29050, GHSA-98f2-w9h9-7fp9
Record: https://patchnext.com/advisories/cve-2026-29050 (revision 1, source checked 26 Oct 2026, 15:19 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: chainguard.dev/melange 0.43.4. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go chainguard.dev/melange: affected >= 0.32.0, < 0.43.4; fixed in 0.43.4

## Suggested inspection (read-only)
- Go chainguard.dev/melange: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on chainguard.dev/melange.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-98f2-w9h9-7fp9 (GitHub-reviewed advisory GHSA-98f2-w9h9-7fp9 lists affected ranges: Go chainguard.dev/melange >=0.32.0 <0.43.4)

Commands are suggestions: review each one before running it.

Loading voting…