Skip to content

← Actionable
Medium, CVSS 6.1amended

changedetection.io has Reflected XSS in its RSS Tag Error Response

CVE-2026-29038GHSA-8whx-v8qq-pq64

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (changedetection-io 0.54.4), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
EPSS
  • CVE-2026-29038: 0.32% estimated exploitation activity in the next 30 days; percentile 24.99 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

A reflected cross-site scripting (XSS) vulnerability was identified in the /rss/tag/ endpoint of changedetection.io. The taguuid path parameter is reflected directly in the HTTP response body without HTML escaping. Since Flask returns text/html by default for plain string responses, the browser parses and executes injected JavaScript. This vulnerability persists in version 0.54.1, which patched the related XSS in /rss/watch/ (CVE-2026-27645 / GHSA-mw8m-398g-h89w) but did not address the identical pattern in the tag RSS endpoint. Package - Ecosystem: pip - Package: changedetection.io - Affected versions: <= 0.54.1 - Patched versions: (none yet) Severity Moderate - CVSS 6.1 CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N Details File: changedetectionio/blueprint/rss/tag.py Line: 36 Source: tag.py @ 1d72716 The taguuid parameter from the URL path is interpolated into the response body using an f-string with no escaping: Flask's default Content-Type for plain string responses is text/html;…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-8whx-v8qq-pq64

  2. Revision 1 · created ·

    Published from osv record GHSA-8whx-v8qq-pq64

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-29038

Advisory: changedetection.io has Reflected XSS in its RSS Tag Error Response
IDs: CVE-2026-29038, GHSA-8whx-v8qq-pq64
Record: https://patchnext.com/advisories/cve-2026-29038 (revision 2, source checked 26 Oct 2026, 13:36 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: changedetection-io 0.54.4. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI changedetection-io: affected < 0.54.4; fixed in 0.54.4

## Suggested inspection (read-only)
- `python -m pip show changedetection-io`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on changedetection-io.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-8whx-v8qq-pq64 (OSV record GHSA-8whx-v8qq-pq64 lists affected ranges: PyPI changedetection-io >=0 <0.54.4 (fixed))
- Verified: https://github.com/advisories/GHSA-8whx-v8qq-pq64 (GitHub-reviewed advisory GHSA-8whx-v8qq-pq64 lists affected ranges: PyPI changedetection-io >=0 <0.54.4)

Commands are suggestions: review each one before running it.

Loading voting…