Skip to content

← Actionable
High, CVSS 8.2amended

@fastify/middie has Improper Path Normalization when Using Path-Scoped Middleware

CVE-2026-2880GHSA-8p85-9qpw-fwgw

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@fastify/middie 9.2.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.2 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-2880: 0.43% estimated exploitation activity in the next 30 days; percentile 37.25 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary A path normalization inconsistency in @fastify/middie can result in authentication/authorization bypass when using path-scoped middleware (for example, app.use('/secret', auth)). When Fastify router normalization options are enabled (such as ignoreDuplicateSlashes, useSemicolonDelimiter, and related trailing-slash behavior), crafted request paths may bypass middleware checks while still being routed to protected handlers. Impact An unauthenticated remote attacker can access endpoints intended to be protected by middleware-based auth/authorization controls by sending specially crafted URL paths (for example, //secret or /secret;foo=bar), depending on router option configuration. This may lead to unauthorized access to protected functionality and data exposure. Affected versions - Confirmed affected: @fastify/middie@9.1.0 - All versions prior to the patch are affected. Patched versions - Fixed in: 9.2.0 Details The issue is caused by canonicalization drift between: 1.…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-8p85-9qpw-fwgw

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-8p85-9qpw-fwgw

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-2880

Advisory: @fastify/middie has Improper Path Normalization when Using Path-Scoped Middleware
IDs: CVE-2026-2880, GHSA-8p85-9qpw-fwgw
Record: https://patchnext.com/advisories/cve-2026-2880 (revision 3, source checked 26 Oct 2026, 12:43 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.2)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @fastify/middie 9.2.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @fastify/middie: affected < 9.2.0; fixed in 9.2.0

## Suggested inspection (read-only)
- `npm ls @fastify/middie --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @fastify/middie.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-8p85-9qpw-fwgw (OSV record GHSA-8p85-9qpw-fwgw lists affected ranges: npm @fastify/middie >=0 <9.2.0 (fixed))
- Verified: https://github.com/advisories/GHSA-8p85-9qpw-fwgw (GitHub-reviewed advisory GHSA-8p85-9qpw-fwgw lists affected ranges: npm @fastify/middie >=0 <9.2.0)

Commands are suggestions: review each one before running it.

Loading voting…