Skip to content

← Actionable
Medium, CVSS 4.3amended

Open WebUI vulnerable to Path Traversal in POST /api/v1/audio/transcriptions

CVE-2026-28786GHSA-vvxm-vxmr-624h

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (open-webui 0.8.6), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
4.3 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
EPSS
  • CVE-2026-28786: 0.57% estimated exploitation activity in the next 30 days; percentile 47.31 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary An unsanitised filename field in the speech-to-text transcription endpoint allows any authenticated non-admin user to trigger a FileNotFoundError whose message — including the server's absolute DATADIR path — is returned verbatim in the HTTP 400 response body, confirming information disclosure on all default deployments. Details backend/openwebui/routers/audio.py:1197 extracts a file extension from the raw multipart filename using file.filename.split(".")[-1] with no path sanitisation. The result is concatenated into a filesystem path and passed to open(): If the filename is audio./etc/passwd, split(".")[-1] yields /etc/passwd and the assembled path becomes: open() fails with FileNotFoundError. The outer except block at line 1231 returns the exception via ERRORMESSAGES.DEFAULT(e), leaking the full absolute path in the response body. The MIME-type guard at line 1190 checks Content-Type (a separate multipart field) and does not constrain filename. Setting Content-Type:…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-vvxm-vxmr-624h

  2. Revision 1 · created ·

    Published from osv record GHSA-vvxm-vxmr-624h

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-28786

Advisory: Open WebUI vulnerable to Path Traversal in `POST /api/v1/audio/transcriptions`
IDs: CVE-2026-28786, GHSA-vvxm-vxmr-624h
Record: https://patchnext.com/advisories/cve-2026-28786 (revision 2, source checked 26 Oct 2026, 13:37 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 4.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: open-webui 0.8.6. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI open-webui: affected < 0.8.6; fixed in 0.8.6

## Suggested inspection (read-only)
- `python -m pip show open-webui`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on open-webui.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-vvxm-vxmr-624h (OSV record GHSA-vvxm-vxmr-624h lists affected ranges: PyPI open-webui >=0 <0.8.6 (fixed))
- Verified: https://github.com/advisories/GHSA-vvxm-vxmr-624h (GitHub-reviewed advisory GHSA-vvxm-vxmr-624h lists affected ranges: PyPI open-webui >=0 <0.8.6)

Commands are suggestions: review each one before running it.

Loading voting…