Craft CMS has Twig Function Blocklist Bypass
CVE-2026-28783GHSA-5fvc-7894-ghp4
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (craftcms/cms 5.9.0-beta.1, 4.17.0-beta.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist craftcms/cms
- Affected
- >= 5.0.0-RC1, < 5.9.0-beta.1>= 4.0.0-RC1, < 4.17.0-beta.1
- Fixed in
- 5.9.0-beta.1, 4.17.0-beta.1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-5fvc-7894-ghp4 lists affected ranges: Packagist craftcms/cms >=5.0.0-RC1 =4.0.0-RC1 <4.17.0-beta.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 6.1 · CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:U · score source
- EPSS
- CVE-2026-28783: 0.51% estimated exploitation activity in the next 30 days; percentile 43.74 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Craft CMS implements a blocklist to prevent potentially dangerous PHP functions from being called via Twig non-Closure arrow functions. In order to be able to successfully execute this attack, you need to either have allowAdminChanges enabled on production, or a compromised admin account, or an account with access to the System Messages utility. Several PHP functions are not included in the blocklist, which could allow malicious actors with the required permissions to execute various types of payloads, including RCEs, arbitrary file reads, SSRFs, and SSTIs. Twig has already deprecated this behavior, and it will eventually be removed from Twig altogether. https://github.com/twigphp/Twig/blob/946ddeafa3c9f4ce279d1f34051af041db0e16f2/src/Extension/CoreExtension.php#L2096 This has been resolved in Craft 4.17.0 and 5.9.0, which removes the blocklist and disables all non-Clousure arrow functions in Twig globally via the enableTwigSandbox config setting. That setting is enabled by default…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-5fvc-7894-ghp4
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-28783 Advisory: Craft CMS has Twig Function Blocklist Bypass IDs: CVE-2026-28783, GHSA-5fvc-7894-ghp4 Record: https://patchnext.com/advisories/cve-2026-28783 (revision 1, source checked 26 Oct 2026, 14:38 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: craftcms/cms 5.9.0-beta.1, 4.17.0-beta.1. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist craftcms/cms: affected >= 5.0.0-RC1, < 5.9.0-beta.1; >= 4.0.0-RC1, < 4.17.0-beta.1; fixed in 5.9.0-beta.1, 4.17.0-beta.1 ## Suggested inspection (read-only) - Packagist craftcms/cms: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on craftcms/cms. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-5fvc-7894-ghp4 (GitHub-reviewed advisory GHSA-5fvc-7894-ghp4 lists affected ranges: Packagist craftcms/cms >=5.0.0-RC1 =4.0.0-RC1 <4.17.0-beta.1) Commands are suggestions: review each one before running it.
Loading voting…