Skip to content

← Actionable
Medium, CVSS 6.8

Mattermost doesn't validate CSRF tokens on an authentication endpoint

CVE-2026-28741GHSA-m7cf-4gh2-v4qg

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/mattermost/mattermost/server/v8 11.5.0, 11.4.3, 11.3.3, 8.0.0-20260220133927-c29cf05d40f8), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Go github.com/mattermost/mattermost/server/v8

    Affected
    >= 8.0.0-20250721062209-4952acea88ce, < 8.0.0-20260220133927-c29cf05d40f8>= 11.5.0-rc1, <= 11.5.0-rc1>= 11.4.0-rc1, < 11.4.3>= 11.3.0-rc1, < 11.3.3
    Fixed in
    11.4.3, 8.0.0-20260220133927-c29cf05d40f8, 11.5.0, 11.3.3

Sources

  • GitHub Advisory Database and maintainer security advisories on GitHub

    GitHub-reviewed advisory GHSA-m7cf-4gh2-v4qg lists affected ranges: Go github.com/mattermost/mattermost/server/v8 >=8.0.0-20250721062209-4952acea88ce =11.5.0-rc1 =11.4.0-rc1 =11.3.0-rc1 <11.3.3

    VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.8 · CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:N
EPSS
  • CVE-2026-28741: 0.13% estimated exploitation activity in the next 30 days; percentile 2.56 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Mattermost versions 10.11.x <= 10.11.12, 11.5.x <= 11.5.0, 11.4.x <= 11.4.2, 11.3.x <= 11.3.2 fail to validate CSRF tokens on an authentication endpoint which allows an attacker to update a user's authentication method via a CSRF attack by tricking a user into visiting a malicious page. Mattermost Advisory ID: MMSA-2026-00625.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-m7cf-4gh2-v4qg

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-28741

Advisory: Mattermost doesn't validate CSRF tokens on an authentication endpoint
IDs: CVE-2026-28741, GHSA-m7cf-4gh2-v4qg
Record: https://patchnext.com/advisories/cve-2026-28741 (revision 1, source checked 26 Oct 2026, 15:19 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: github.com/mattermost/mattermost/server/v8 11.5.0, 11.4.3, 11.3.3, 8.0.0-20260220133927-c29cf05d40f8. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/mattermost/mattermost/server/v8: affected >= 8.0.0-20250721062209-4952acea88ce, < 8.0.0-20260220133927-c29cf05d40f8; >= 11.5.0-rc1, <= 11.5.0-rc1; >= 11.4.0-rc1, < 11.4.3; >= 11.3.0-rc1, < 11.3.3; fixed in 11.4.3, 8.0.0-20260220133927-c29cf05d40f8, 11.5.0, 11.3.3

## Suggested inspection (read-only)
- Go github.com/mattermost/mattermost/server/v8: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/mattermost/mattermost/server/v8.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-m7cf-4gh2-v4qg (GitHub-reviewed advisory GHSA-m7cf-4gh2-v4qg lists affected ranges: Go github.com/mattermost/mattermost/server/v8 >=8.0.0-20250721062209-4952acea88ce =11.5.0-rc1 =11.4.0-rc1 =11.3.0-rc1 <11.3.3)

Commands are suggestions: review each one before running it.

Loading voting…