Skip to content

← Actionable
High, CVSS 8.7

Gitea: Stored XSS via glTF extensionsRequired in Gitea 3D File Viewer

CVE-2026-28737GHSA-9cpj-qc93-vw8v

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (code.gitea.io/gitea 1.26.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.7 · CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:N
EPSS
  • CVE-2026-28737: 0.41% estimated exploitation activity in the next 30 days; percentile 35.46 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary Me again. Gitea's built-in 3D file viewer (powered by Online3DViewer) is vulnerable to stored cross-site scripting (XSS) through crafted .gltf files. When a glTF file declares an unsupported required extension, Online3DViewer generates an error message containing the extension name and Gitea inserts it into the DOM using innerHTML without sanitization. An attacker who can push a .gltf file to any repository can execute arbitrary JavaScript in the context of any user who views the file. Affected Versions - Gitea 1.25.0 and later (3D file preview was introduced in 1.25 via the Online3DViewer integration) - Confirmed on gitea:1.25-nightly (SHA e33d1da...), which bundles online-3d-viewer npm package v0.16.0 - The upstream Online3DViewer library is the root cause Severity - Stored XSS: the payload persists in the repository and fires on every page view - Executes under the Gitea origin with the victim's session (cookies, CSRF tokens) - Any authenticated user viewing the file is…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-9cpj-qc93-vw8v

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-28737

Advisory: Gitea: Stored XSS via glTF `extensionsRequired` in Gitea 3D File Viewer
IDs: CVE-2026-28737, GHSA-9cpj-qc93-vw8v
Record: https://patchnext.com/advisories/cve-2026-28737 (revision 1, source checked 26 Oct 2026, 15:24 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: code.gitea.io/gitea 1.26.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go code.gitea.io/gitea: affected >= 1.25.0, < 1.26.0; fixed in 1.26.0

## Suggested inspection (read-only)
- Go code.gitea.io/gitea: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on code.gitea.io/gitea.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-9cpj-qc93-vw8v (GitHub-reviewed advisory GHSA-9cpj-qc93-vw8v lists affected ranges: Go code.gitea.io/gitea >=1.25.0 <1.26.0)

Commands are suggestions: review each one before running it.

Loading voting…