Mattermost doesn't enforce slash command trigger-word uniqueness during command updates
CVE-2026-28732GHSA-wvcv-9xpm-7mqc
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/mattermost/mattermost/server/v8 11.5.2, 11.4.4, 10.11.14, 8.0.0-20260306123948-f5fe8ded6b63; github.com/mattermost/mattermost-server 5.3.2-0.20260306123948-f5fe8ded6b63), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Go github.com/mattermost/mattermost/server/v8
- Affected
- >= 11.5.0, < 11.5.2>= 10.11.0, < 10.11.14>= 11.4.0, < 11.4.4< 8.0.0-20260306123948-f5fe8ded6b63
- Fixed in
- 11.4.4, 10.11.14, 11.5.2, 8.0.0-20260306123948-f5fe8ded6b63
Go github.com/mattermost/mattermost-server
- Affected
- < 5.3.2-0.20260306123948-f5fe8ded6b63
- Fixed in
- 5.3.2-0.20260306123948-f5fe8ded6b63
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-wvcv-9xpm-7mqc lists affected ranges: Go github.com/mattermost/mattermost/server/v8 >=11.5.0 =10.11.0 =11.4.0 =0 =0 <5.3.2-0.20260306123948-f5fe8ded6b63
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 4.3 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N
- EPSS
- CVE-2026-28732: 0.15% estimated exploitation activity in the next 30 days; percentile 4.40 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Mattermost versions 11.5.x <= 11.5.1, 10.11.x <= 10.11.13, 11.4.x <= 11.4.3 Fail to enforce slash command trigger-word uniqueness during command updates which allows an authenticated team member with Manage Own Slash Commands permission to hijack and impersonate existing system or custom slash commands via editing their own slash command trigger to an already-registered trigger through the command update API. Mattermost Advisory ID: MMSA-2026-00597
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-wvcv-9xpm-7mqc
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-28732 Advisory: Mattermost doesn't enforce slash command trigger-word uniqueness during command updates IDs: CVE-2026-28732, GHSA-wvcv-9xpm-7mqc Record: https://patchnext.com/advisories/cve-2026-28732 (revision 1, source checked 26 Oct 2026, 15:23 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 4.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/mattermost/mattermost/server/v8 11.5.2, 11.4.4, 10.11.14, 8.0.0-20260306123948-f5fe8ded6b63; github.com/mattermost/mattermost-server 5.3.2-0.20260306123948-f5fe8ded6b63. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/mattermost/mattermost/server/v8: affected >= 11.5.0, < 11.5.2; >= 10.11.0, < 10.11.14; >= 11.4.0, < 11.4.4; < 8.0.0-20260306123948-f5fe8ded6b63; fixed in 11.4.4, 10.11.14, 11.5.2, 8.0.0-20260306123948-f5fe8ded6b63 - Go github.com/mattermost/mattermost-server: affected < 5.3.2-0.20260306123948-f5fe8ded6b63; fixed in 5.3.2-0.20260306123948-f5fe8ded6b63 ## Suggested inspection (read-only) - Go github.com/mattermost/mattermost/server/v8: check the installed version with your package manager. - Go github.com/mattermost/mattermost-server: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/mattermost/mattermost/server/v8, github.com/mattermost/mattermost-server. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-wvcv-9xpm-7mqc (GitHub-reviewed advisory GHSA-wvcv-9xpm-7mqc lists affected ranges: Go github.com/mattermost/mattermost/server/v8 >=11.5.0 =10.11.0 =11.4.0 =0 =0 <5.3.2-0.20260306123948-f5fe8ded6b63) Commands are suggestions: review each one before running it.
Loading voting…