Skip to content

← Actionable
High, CVSS 8.1

Gitea: OAuth2 access token scope enforcement bypass via HTTP Basic authentication

CVE-2026-28699GHSA-9r5x-wg6m-x2rc

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (code.gitea.io/gitea 1.26.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.1 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N
EPSS
  • CVE-2026-28699: 0.55% estimated exploitation activity in the next 30 days; percentile 46.13 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary Gitea fails to enforce OAuth2 access token scopes when the token is submitted via HTTP Basic authentication instead of a Bearer token. An OAuth2 application granted only read:user can use the same token as Authorization: Basic base64(<token:x-oauth-basic) and perform write actions, including modifying profiles, adding email addresses, creating repositories, and deleting repositories as the authorizing user. Details Root cause: services/auth/basic.go accepts OAuth2 access tokens through the Basic auth path but does not store the token scope in the request context: The scope enforcement middleware in routers/api/v1/api.go exits early when ApiTokenScope is absent: When a token arrives via Bearer, ApiTokenScope is populated and scope checks apply normally. When the same token arrives via Basic auth, ApiTokenScope is never set, so tokenRequiresScopes returns immediately and no scope is enforced. Suggested fix: When an OAuth2 access token is accepted in services/auth/basic.go,…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-9r5x-wg6m-x2rc

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-28699

Advisory: Gitea: OAuth2 access token scope enforcement bypass via HTTP Basic authentication
IDs: CVE-2026-28699, GHSA-9r5x-wg6m-x2rc
Record: https://patchnext.com/advisories/cve-2026-28699 (revision 1, source checked 26 Oct 2026, 15:23 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: code.gitea.io/gitea 1.26.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go code.gitea.io/gitea: affected <= 1.26.1; fixed in 1.26.2

## Suggested inspection (read-only)
- Go code.gitea.io/gitea: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on code.gitea.io/gitea.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-9r5x-wg6m-x2rc (GitHub-reviewed advisory GHSA-9r5x-wg6m-x2rc lists affected ranges: Go code.gitea.io/gitea >=0 <=1.26.1)

Commands are suggestions: review each one before running it.

Loading voting…