Craft CMS Vulnerable to Authenticated RCE via "craft.app.fs.write()" in Twig Templates
CVE-2026-28697GHSA-v47q-jxvr-p68x
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (craftcms/cms 5.9.0-beta.1, 4.17.0-beta.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist craftcms/cms
- Affected
- >= 5.0.0-RC1, < 5.9.0-beta.1>= 4.0.0-RC1, < 4.17.0-beta.1
- Fixed in
- 5.9.0-beta.1, 4.17.0-beta.1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-v47q-jxvr-p68x lists affected ranges: Packagist craftcms/cms >=5.0.0-RC1 =4.0.0-RC1 <4.17.0-beta.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 9.4 · CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H · score source
- EPSS
- CVE-2026-28697: 1.19% estimated exploitation activity in the next 30 days; percentile 67.93 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary An authenticated administrator can achieve Remote Code Execution (RCE) by injecting a Server-Side Template Injection (SSTI) payload into Twig template fields (e.g., Email Templates). By calling the craft.app.fs.write() method, an attacker can write a malicious PHP script to a web-accessible directory and subsequently access it via the browser to execute arbitrary system commands. --- Proof of Concept Attack Prerequisites - Authenticated administrator account with allowAdminChanges enabled, or access to the System Messages utility Steps to Reproduce 1. Navigate to Utilities → System Messages (/admin/utilities/system-messages) 2. Edit any email template (e.g., "Test Email") and inject the following in the body (or the Subject): - To exploit it by writing to a file system: - Note: Replace the filesystem handle (e.g., hardDisk) with a valid handle configured in the target installation. - To exploit it by writing to a volume: - Note: Replace the volume handle (e.g., images) with a…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-v47q-jxvr-p68x
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-28697 Advisory: Craft CMS Vulnerable to Authenticated RCE via "craft.app.fs.write()" in Twig Templates IDs: CVE-2026-28697, GHSA-v47q-jxvr-p68x Record: https://patchnext.com/advisories/cve-2026-28697 (revision 1, source checked 26 Oct 2026, 14:38 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.4) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: craftcms/cms 5.9.0-beta.1, 4.17.0-beta.1. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist craftcms/cms: affected >= 5.0.0-RC1, < 5.9.0-beta.1; >= 4.0.0-RC1, < 4.17.0-beta.1; fixed in 5.9.0-beta.1, 4.17.0-beta.1 ## Suggested inspection (read-only) - Packagist craftcms/cms: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on craftcms/cms. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-v47q-jxvr-p68x (GitHub-reviewed advisory GHSA-v47q-jxvr-p68x lists affected ranges: Packagist craftcms/cms >=5.0.0-RC1 =4.0.0-RC1 <4.17.0-beta.1) Commands are suggestions: review each one before running it.
Loading voting…