Craft CMS Vulnerable to Authenticated RCE via Twig SSTI - create() function + Symfony Process gadget
CVE-2026-28695GHSA-94rc-cqvm-m4pw
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (craftcms/cms 5.9.0-beta.1, 4.17.0-beta.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist craftcms/cms
- Affected
- >= 5.8.7, < 5.9.0-beta.1>= 4.0.0-RC1, < 4.17.0-beta.1
- Fixed in
- 5.9.0-beta.1, 4.17.0-beta.1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-94rc-cqvm-m4pw lists affected ranges: Packagist craftcms/cms >=5.8.7 =4.0.0-RC1 <4.17.0-beta.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 6.6 · CVSS:4.0/AV:N/AC:L/AT:P/PR:H/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:P · score source
- EPSS
- CVE-2026-28695: 0.66% estimated exploitation activity in the next 30 days; percentile 51.70 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
There is an authenticated admin RCE in Craft CMS 5.8.21 via Server-Side Template Injection using the create() Twig function combined with a Symfony Process gadget chain. This bypasses the fix implemented for CVE-2025-57811 (patched in 5.8.7). Required Permissions - Administrator permissions or access to System Messages utility - allowAdminChanges enabled in production (against our security recommendations) or access to System Messages utility Vulnerability Details The create() Twig function exposes Craft::createObject(), which allows instantiation of arbitrary PHP classes with constructor arguments. Combined with the bundled symfony/process dependency, this enables RCE. Attack Vector Admin panel → Settings → Entry Types → Title Format field Proof of Concept Payload Steps to Reproduce 1. Log in as admin 2. Navigate to Settings → Entry Types 3. Edit any entry type’s "Title Format" field 4. Insert the payload above 5. Create/edit an entry of that type 6. Command executes, output appears…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-94rc-cqvm-m4pw
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-28695 Advisory: Craft CMS Vulnerable to Authenticated RCE via Twig SSTI - create() function + Symfony Process gadget IDs: CVE-2026-28695, GHSA-94rc-cqvm-m4pw Record: https://patchnext.com/advisories/cve-2026-28695 (revision 1, source checked 26 Oct 2026, 14:38 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.6) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: craftcms/cms 5.9.0-beta.1, 4.17.0-beta.1. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist craftcms/cms: affected >= 5.8.7, < 5.9.0-beta.1; >= 4.0.0-RC1, < 4.17.0-beta.1; fixed in 5.9.0-beta.1, 4.17.0-beta.1 ## Suggested inspection (read-only) - Packagist craftcms/cms: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on craftcms/cms. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-94rc-cqvm-m4pw (GitHub-reviewed advisory GHSA-94rc-cqvm-m4pw lists affected ranges: Packagist craftcms/cms >=5.8.7 =4.0.0-RC1 <4.17.0-beta.1) Commands are suggestions: review each one before running it.
Loading voting…