Skip to content

← Actionable
High, CVSS 8.5

Pocket ID: OIDC authorization code validation uses AND instead of OR, allowing cross-client token exchange

CVE-2026-28513GHSA-qh6q-598w-w6m2

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/pocket-id/pocket-id/backend 0.0.0-20260307173642-b59e35cb59ae), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.5 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:L/A:N
EPSS
  • CVE-2026-28513: 0.29% estimated exploitation activity in the next 30 days; percentile 21.47 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary The OIDC token endpoint rejects an authorization code only when both the client ID is wrong and the code is expired. This allows cross-client code exchange and expired code reuse. Details backend/internal/service/oidcservice.go:407 && should be ||. Current behavior: | Condition | Expected | Actual | |-----------|----------|--------| | Wrong client + valid code | Reject | Accept | | Correct client + expired code | Reject | Accept | PoC Prerequisite: pocket-id running with APPENV=test and BUILDTAGS=e2etest. The test user (Tim Cook) must have authorized both Nextcloud and Immich OIDC clients (i.e., userauthorizedoidcclients records exist for both). The seed data includes an authorization code auth-code issued for the Nextcloud client. Verified result: HTTP 200 with tokens. The accesstoken audience is 606c7782-... (Immich), despite the authorization code being issued for 3654a746-... (Nextcloud). Impact Any OIDC client operator can exchange authorization codes issued for other…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-qh6q-598w-w6m2

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-28513

Advisory: Pocket ID: OIDC authorization code validation uses AND instead of OR, allowing cross-client token exchange
IDs: CVE-2026-28513, GHSA-qh6q-598w-w6m2
Record: https://patchnext.com/advisories/cve-2026-28513 (revision 1, source checked 26 Oct 2026, 15:15 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: github.com/pocket-id/pocket-id/backend 0.0.0-20260307173642-b59e35cb59ae. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/pocket-id/pocket-id/backend: affected < 0.0.0-20260307173642-b59e35cb59ae; fixed in 0.0.0-20260307173642-b59e35cb59ae

## Suggested inspection (read-only)
- Go github.com/pocket-id/pocket-id/backend: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/pocket-id/pocket-id/backend.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-qh6q-598w-w6m2 (GitHub-reviewed advisory GHSA-qh6q-598w-w6m2 lists affected ranges: Go github.com/pocket-id/pocket-id/backend >=0 <0.0.0-20260307173642-b59e35cb59ae)

Commands are suggestions: review each one before running it.

Loading voting…