Skip to content

← Actionable
High, CVSS 8.6

Idno Vulnerable to Remote Code Execution via Chained Import File Write and Template Path Traversal

CVE-2026-28507GHSA-37j7-56xc-c468

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (idno/known 1.6.4), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.6 · CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:H/VI:H/VA:H/SC:L/SI:L/SA:N · score source
EPSS
  • CVE-2026-28507: 0.77% estimated exploitation activity in the next 30 days; percentile 55.52 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Affected Versions: Tested on current dev branch (build fingerprint 505[...]7bd86) CVSS v4 Score: 8.6 (CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N) Privileges Required: Web application admin account (for file write), any authenticated user (for RCE trigger) --- Summary Two separate vulnerabilities in Idno can be chained to achieve RCE from a web application admin account. A web application admin can cause the server to fetch an attacker-controlled URL during WordPress import processing, writing a PHP file to the server's temp directory. The admin or a separate, lower-privileged authenticated user can then trigger inclusion of that file via an unsanitized template name parameter, executing arbitrary operating system commands as the web server user. --- Vulnerability 1: Arbitrary PHP File Write via WordPress Import (SSRF + File Write) Location Idno/Core/Migration.php — importImagesFromBodyHTML() Required Privilege Web application admin (any user with the admin flag…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-37j7-56xc-c468

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-28507

Advisory: Idno Vulnerable to Remote Code Execution via Chained Import File Write and Template Path Traversal
IDs: CVE-2026-28507, GHSA-37j7-56xc-c468
Record: https://patchnext.com/advisories/cve-2026-28507 (revision 1, source checked 26 Oct 2026, 14:38 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.6)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: idno/known 1.6.4. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist idno/known: affected < 1.6.4; fixed in 1.6.4

## Suggested inspection (read-only)
- Packagist idno/known: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on idno/known.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-37j7-56xc-c468 (GitHub-reviewed advisory GHSA-37j7-56xc-c468 lists affected ranges: Packagist idno/known >=0 <1.6.4)

Commands are suggestions: review each one before running it.

Loading voting…