ONNX Untrusted Model Repository Warnings Suppressed by silent=True in onnx.hub.load() — Silent Supply-Chain Attack
CVE-2026-28500GHSA-hqmj-h5c6-369m
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (onnx 1.21.0rc1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI onnx
- Affected
- <= 1.20.1
- Fixed in
- 1.21.0rc1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-hqmj-h5c6-369m lists affected ranges: PyPI onnx >=0 <1.21.0rc1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-hqmj-h5c6-369m lists affected ranges: PyPI onnx >=0 <=1.20.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.6 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:N/A:N
- EPSS
- CVE-2026-28500: 0.32% estimated exploitation activity in the next 30 days; percentile 25.43 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
What's the issue Passing silent=True to onnx.hub.load() kills all trust warnings and user prompts. This means a model can be downloaded from any unverified GitHub repo with zero user awareness. On top of that, the SHA256 integrity check is useless here — it validates against a manifest that lives in the same repo the attacker controls, so the hash will always match. Impact Any pipeline using hub.load() with silent=True and an external repo string is silently loading whatever the repo owner ships. If that model executes arbitrary code on load, the attacker has access to the machine. Resolved by removing the feature References - Write-up
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-hqmj-h5c6-369m
- Revision 1 · created ·
Published from osv record GHSA-hqmj-h5c6-369m
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-28500 Advisory: ONNX Untrusted Model Repository Warnings Suppressed by silent=True in onnx.hub.load() — Silent Supply-Chain Attack IDs: CVE-2026-28500, GHSA-hqmj-h5c6-369m Record: https://patchnext.com/advisories/cve-2026-28500 (revision 2, source checked 26 Oct 2026, 13:44 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.6) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: onnx 1.21.0rc1. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI onnx: affected <= 1.20.1; fixed in 1.21.0rc1 ## Suggested inspection (read-only) - `python -m pip show onnx`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on onnx. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-hqmj-h5c6-369m (OSV record GHSA-hqmj-h5c6-369m lists affected ranges: PyPI onnx >=0 <1.21.0rc1 (fixed)) - Verified: https://github.com/advisories/GHSA-hqmj-h5c6-369m (GitHub-reviewed advisory GHSA-hqmj-h5c6-369m lists affected ranges: PyPI onnx >=0 <=1.20.1) Commands are suggestions: review each one before running it.
Loading voting…