Authlib: Fail-Open Cryptographic Verification in OIDC Hash Binding
CVE-2026-28498GHSA-m344-f55w-2m6j
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (authlib 1.6.9), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI authlib
- Affected
- <= 1.6.8
- Fixed in
- 1.6.9
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-m344-f55w-2m6j lists affected ranges: PyPI authlib >=0 <1.6.9 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-m344-f55w-2m6j lists affected ranges: PyPI authlib >=0 <=1.6.8
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 8.2 · CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2026-28498: 0.24% estimated exploitation activity in the next 30 days; percentile 15.17 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
1. Executive Summary A critical library-level vulnerability was identified in the Authlib Python library concerning the validation of OpenID Connect (OIDC) ID Tokens. Specifically, the internal hash verification logic (verifyhash) responsible for validating the athash (Access Token Hash) and chash (Authorization Code Hash) claims exhibits a fail-open behavior when encountering an unsupported or unknown cryptographic algorithm. This flaw allows an attacker to bypass mandatory integrity protections by supplying a forged ID Token with a deliberately unrecognized alg header parameter. The library intercepts the unsupported state and silently returns True (validation passed), inherently violating fundamental cryptographic design principles and direct OIDC specifications. --- 2. Technical Details & Root Cause The vulnerability resides within the verifyhash(signature, s, alg) function in authlib/oidc/core/claims.py: When an unsupported algorithm string (e.g., "XX999") is processed by the…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-m344-f55w-2m6j
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-m344-f55w-2m6j
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-28498 Advisory: Authlib: Fail-Open Cryptographic Verification in OIDC Hash Binding IDs: CVE-2026-28498, GHSA-m344-f55w-2m6j Record: https://patchnext.com/advisories/cve-2026-28498 (revision 3, source checked 26 Oct 2026, 13:37 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.2) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: authlib 1.6.9. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI authlib: affected <= 1.6.8; fixed in 1.6.9 ## Suggested inspection (read-only) - `python -m pip show authlib`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on authlib. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-m344-f55w-2m6j (OSV record GHSA-m344-f55w-2m6j lists affected ranges: PyPI authlib >=0 <1.6.9 (fixed)) - Verified: https://github.com/advisories/GHSA-m344-f55w-2m6j (GitHub-reviewed advisory GHSA-m344-f55w-2m6j lists affected ranges: PyPI authlib >=0 <=1.6.8) Commands are suggestions: review each one before running it.
Loading voting…