Authlib Vulnerable to JWE RSA1_5 Bleichenbacher Padding Oracle
CVE-2026-28490GHSA-7432-952r-cw78
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (authlib 1.6.9), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI authlib
- Affected
- <= 1.6.8
- Fixed in
- 1.6.9
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-7432-952r-cw78 lists affected ranges: PyPI authlib >=0 <1.6.9 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-7432-952r-cw78 lists affected ranges: PyPI authlib >=0 <=1.6.8
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 8.3 · CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:H/VI:L/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2026-28490: 0.14% estimated exploitation activity in the next 30 days; percentile 3.72 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
1. Executive Summary A cryptographic padding oracle vulnerability was identified in the Authlib Python library concerning the implementation of the JSON Web Encryption (JWE) RSA15 key management algorithm. Authlib registers RSA15 in its default algorithm registry without requiring explicit opt-in, and actively destroys the constant-time Bleichenbacher mitigation that the underlying cryptography library implements correctly. When cryptography encounters an invalid PKCS#1 v1.5 padding, it returns a randomized byte string instead of raising an exception — the correct behavior per RFC 3218 §2.3.2. Authlib ignores this contract and raises ValueError('Invalid "cek" length') immediately after decryption, before reaching AES-GCM tag validation. This creates a clean, reliable Exception Oracle: - Invalid padding → cryptography returns random bytes → Authlib length check fails → ValueError: Invalid "cek" length - Valid padding, wrong MAC → decryption succeeds → length check passes → AES-GCM…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-7432-952r-cw78
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-7432-952r-cw78
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-28490 Advisory: Authlib Vulnerable to JWE RSA1_5 Bleichenbacher Padding Oracle IDs: CVE-2026-28490, GHSA-7432-952r-cw78 Record: https://patchnext.com/advisories/cve-2026-28490 (revision 3, source checked 26 Oct 2026, 13:37 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: authlib 1.6.9. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI authlib: affected <= 1.6.8; fixed in 1.6.9 ## Suggested inspection (read-only) - `python -m pip show authlib`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on authlib. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-7432-952r-cw78 (OSV record GHSA-7432-952r-cw78 lists affected ranges: PyPI authlib >=0 <1.6.9 (fixed)) - Verified: https://github.com/advisories/GHSA-7432-952r-cw78 (GitHub-reviewed advisory GHSA-7432-952r-cw78 lists affected ranges: PyPI authlib >=0 <=1.6.8) Commands are suggestions: review each one before running it.
Loading voting…