Skip to content

← Actionable
High, CVSS 7.5amended

OpenClaw affected by denial of service via unbounded webhook request body buffering

CVE-2026-28478GHSA-q447-rj3r-2cgh

What to do

Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm openclaw

    Affected
    < 2026.2.13
    Fixed in
    2026.2.13
  • npm clawdbot

    Affected
    <= 2026.1.24-3
    Fixed in
    no fixed version recorded

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2026-28478: 0.51% estimated exploitation activity in the next 30 days; percentile 43.31 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary Multiple webhook handlers accepted and buffered request bodies without a strict unified byte/time limit. A remote unauthenticated attacker could send oversized payloads and cause memory pressure, degrading availability. Details Affected packages: - openclaw (npm): <2026.2.12 - clawdbot (npm): <=2026.1.24-3 Root cause: - Webhook code paths buffered request payloads without consistent maxBytes + timeoutMs enforcement. - Some SDK-backed handlers parse request bodies internally and needed stream-level guards. Attack shape: - Send very large JSON payloads or slow/incomplete uploads to webhook endpoints. - Observe elevated memory usage and request handler pressure. Impact Remote unauthenticated availability impact (DoS) via request body amplification/memory pressure. Patch details (implemented) - Added shared bounded request-body helper in src/infra/http-body.ts. - Exported helper in src/plugin-sdk/index.ts for extension reuse. - Migrated webhook body readers to shared helper for:…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-q447-rj3r-2cgh

  2. Revision 1 · created ·

    Published from osv record GHSA-q447-rj3r-2cgh

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-28478

Advisory: OpenClaw affected by denial of service via unbounded webhook request body buffering
IDs: CVE-2026-28478, GHSA-q447-rj3r-2cgh
Record: https://patchnext.com/advisories/cve-2026-28478 (revision 2, source checked 26 Oct 2026, 12:43 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Partial vendor fix; fixed versions by package: openclaw 2026.2.13. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm openclaw: affected < 2026.2.13; fixed in 2026.2.13
- npm clawdbot: affected <= 2026.1.24-3

## Suggested inspection (read-only)
- `npm ls openclaw --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.
- `npm ls clawdbot --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on openclaw, clawdbot.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-q447-rj3r-2cgh (OSV record GHSA-q447-rj3r-2cgh lists affected ranges: npm openclaw >=0 =0 <=2026.1.24-3)
- Verified: https://github.com/advisories/GHSA-q447-rj3r-2cgh (GitHub-reviewed advisory GHSA-q447-rj3r-2cgh lists affected ranges: npm openclaw >=0 =0 <=2026.1.24-3)

Commands are suggestions: review each one before running it.

Loading voting…