Skip to content

← Actionable
Medium, CVSS 6.3amended

OpenClaw affected by SSRF in optional Tlon (Urbit) extension authentication

CVE-2026-28476GHSA-pg2v-8xwh-qhcc

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (openclaw 2026.2.14), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm openclaw

    Affected
    < 2026.2.14
    Fixed in
    2026.2.14

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
6.3 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:L/VA:N/SC:L/SI:L/SA:L · score source
EPSS
  • CVE-2026-28476: 0.28% estimated exploitation activity in the next 30 days; percentile 20.64 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary The optional Tlon (Urbit) extension previously accepted a user-provided base URL for authentication and used it to construct an outbound HTTP request, enabling server-side request forgery (SSRF) in affected deployments. Impact This only affects deployments that have installed and configured the Tlon (Urbit) extension, and where an attacker can influence the configured Urbit URL. Under those conditions, the gateway could be induced to make HTTP requests to attacker-chosen hosts (including internal addresses). Deployments that do not use the Tlon extension, or where untrusted users cannot change the Urbit URL, are not impacted. Affected Packages / Versions - Package: openclaw (npm) - Affected versions: <= 2026.2.13 Fixed Versions - 2026.2.14 (planned next release) Fix Commit(s) - bfa7d21e997baa8e3437657d59b1e296815cc1b1 Details Urbit authentication now validates and normalizes the base URL and uses an SSRF guard that blocks private/internal hosts by default (opt-in:…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-pg2v-8xwh-qhcc

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-pg2v-8xwh-qhcc

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-28476

Advisory: OpenClaw affected by SSRF in optional Tlon (Urbit) extension authentication
IDs: CVE-2026-28476, GHSA-pg2v-8xwh-qhcc
Record: https://patchnext.com/advisories/cve-2026-28476 (revision 3, source checked 26 Oct 2026, 12:51 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: openclaw 2026.2.14. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm openclaw: affected < 2026.2.14; fixed in 2026.2.14

## Suggested inspection (read-only)
- `npm ls openclaw --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on openclaw.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-pg2v-8xwh-qhcc (OSV record GHSA-pg2v-8xwh-qhcc lists affected ranges: npm openclaw >=0 <2026.2.14 (fixed))
- Verified: https://github.com/advisories/GHSA-pg2v-8xwh-qhcc (GitHub-reviewed advisory GHSA-pg2v-8xwh-qhcc lists affected ranges: npm openclaw >=0 <2026.2.14)

Commands are suggestions: review each one before running it.

Loading voting…