Skip to content

← Actionable
Critical, CVSS 9.3amended

Nextcloud Talk allowlist bypass via actor.name display name spoofing

CVE-2026-28474GHSA-r5h9-vjqc-hq3r

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@openclaw/nextcloud-talk 2026.2.6), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
9.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-28474: 0.55% estimated exploitation activity in the next 30 days; percentile 46.26 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary In affected versions of the optional Nextcloud Talk plugin (installed separately; not bundled with the core OpenClaw install), an untrusted webhook field (actor.name, display name) could be treated as an allowlist identifier. An attacker could change their Nextcloud display name to match an allowlisted user ID and bypass DM or room allowlists. Details Nextcloud Talk webhook payloads provide a stable sender identifier (actor.id) and a mutable display name (actor.name). In affected versions, the plugin’s allowlist matching accepted equality on the display name, which is attacker-controlled. Affected Packages / Versions - Package: @openclaw/nextcloud-talk (npm) - Affected: <= 2026.2.2 - Fixed: = 2026.2.6 Note: This advisory applies to the optional Nextcloud Talk plugin package. Core openclaw is not impacted unless you installed and use @openclaw/nextcloud-talk. Fix Commit(s) - 6b4b6049b47c3329a7014509594647826669892d Timeline - Introduced:…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 4 · amended ·

    Amended from ghsa record GHSA-r5h9-vjqc-hq3r

  2. Revision 3 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 2 · amended ·

    Amended from osv record GHSA-r5h9-vjqc-hq3r

  4. Revision 1 · created ·

    Published from ghsa record GHSA-r5h9-vjqc-hq3r

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-28474

Advisory: Nextcloud Talk allowlist bypass via actor.name display name spoofing
IDs: CVE-2026-28474, GHSA-r5h9-vjqc-hq3r
Record: https://patchnext.com/advisories/cve-2026-28474 (revision 4, source checked 26 Oct 2026, 12:42 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @openclaw/nextcloud-talk 2026.2.6. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @openclaw/nextcloud-talk: affected <= 2026.2.2; fixed in 2026.2.6

## Suggested inspection (read-only)
- `npm ls @openclaw/nextcloud-talk --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @openclaw/nextcloud-talk.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-r5h9-vjqc-hq3r (GitHub-reviewed advisory GHSA-r5h9-vjqc-hq3r lists affected ranges: npm @openclaw/nextcloud-talk >=0 <=2026.2.2)
- Verified: https://osv.dev/vulnerability/GHSA-r5h9-vjqc-hq3r (OSV record GHSA-r5h9-vjqc-hq3r lists affected ranges: npm @openclaw/nextcloud-talk >=0 <2026.2.6 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…