OpenClaw authorization bypass: operator.write can resolve exec approvals via chat.send -> /approve
CVE-2026-28473GHSA-mqpw-46fh-299h
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (openclaw 2026.2.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm openclaw
- Affected
- < 2026.2.2
- Fixed in
- 2026.2.2
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-mqpw-46fh-299h lists affected ranges: npm openclaw >=0 <2026.2.2 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-mqpw-46fh-299h lists affected ranges: npm openclaw >=0 <2026.2.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 7.2 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:H/VA:H/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2026-28473: 0.33% estimated exploitation activity in the next 30 days; percentile 25.84 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary What this means (plain language) If you give a client “chat/write” access to the gateway (operator.write) but you do not intend to let that client approve exec requests (operator.approvals), affected versions could still let that client approve/deny a pending exec approval by sending the /approve chat command. This is mainly relevant for shared or multi-client setups where different tokens are intentionally scoped differently. Single-operator installs are typically less impacted. Technical summary A gateway client authenticated with a device token scoped only to operator.write (without operator.approvals) could approve/deny pending exec approval requests by sending a chat message containing the built-in /approve command. exec.approval.resolve is correctly scoped to operator.approvals for direct RPC calls, but the /approve command path invoked it via an internal privileged gateway client. Affected Packages / Versions - openclaw (npm): < 2026.2.2 Fix - Fixed in openclaw…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-mqpw-46fh-299h
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-mqpw-46fh-299h
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-28473 Advisory: OpenClaw authorization bypass: operator.write can resolve exec approvals via chat.send -> /approve IDs: CVE-2026-28473, GHSA-mqpw-46fh-299h Record: https://patchnext.com/advisories/cve-2026-28473 (revision 3, source checked 26 Oct 2026, 12:43 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.2) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: openclaw 2026.2.2. A vendor fix does not mean a deployment is fixed. ## Affected components - npm openclaw: affected < 2026.2.2; fixed in 2026.2.2 ## Suggested inspection (read-only) - `npm ls openclaw --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on openclaw. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-mqpw-46fh-299h (OSV record GHSA-mqpw-46fh-299h lists affected ranges: npm openclaw >=0 <2026.2.2 (fixed)) - Verified: https://github.com/advisories/GHSA-mqpw-46fh-299h (GitHub-reviewed advisory GHSA-mqpw-46fh-299h lists affected ranges: npm openclaw >=0 <2026.2.2) Commands are suggestions: review each one before running it.
Loading voting…