Skip to content

← Actionable
Critical, CVSS 9.4amended

OpenClaw Vulnerable to Remote Code Execution via Node Invoke Approval Bypass in Gateway

CVE-2026-28466GHSA-gv46-4xfq-jv58

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (openclaw 2026.2.14), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm openclaw

    Affected
    < 2026.2.14
    Fixed in
    2026.2.14

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
9.4 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H · score source
EPSS
  • CVE-2026-28466: 0.47% estimated exploitation activity in the next 30 days; percentile 41.00 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary A remote code execution (RCE) vulnerability in the gateway-to-node invocation path allowed an authenticated gateway client to bypass node-host exec approvals by injecting internal control fields into node.invoke parameters. Affected Component - Gateway method: node.invoke for node command system.run - Node host runner: exec approval gating for system.run Impact If an attacker can authenticate to a gateway (for example via a leaked/shared gateway token or a paired device token with operator.write), they could execute arbitrary commands on connected node hosts that support system.run. This can lead to full compromise of developer workstations, CI runners, and servers running the node host. Technical Details The gateway forwarded user-controlled params to node hosts without sanitizing internal approval fields. The node host treated params.approved === true and/or params.approvalDecision as sufficient to skip the approval workflow. Fix Patched in OpenClaw 2026.2.14. - Commits: -…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 4 · amended ·

    Amended from ghsa record GHSA-gv46-4xfq-jv58

  2. Revision 3 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 2 · amended ·

    Amended from osv record GHSA-gv46-4xfq-jv58

  4. Revision 1 · created ·

    Published from ghsa record GHSA-gv46-4xfq-jv58

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-28466

Advisory: OpenClaw Vulnerable to Remote Code Execution via Node Invoke Approval Bypass in Gateway
IDs: CVE-2026-28466, GHSA-gv46-4xfq-jv58
Record: https://patchnext.com/advisories/cve-2026-28466 (revision 4, source checked 26 Oct 2026, 12:43 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.4)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: openclaw 2026.2.14. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm openclaw: affected < 2026.2.14; fixed in 2026.2.14

## Suggested inspection (read-only)
- `npm ls openclaw --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on openclaw.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-gv46-4xfq-jv58 (GitHub-reviewed advisory GHSA-gv46-4xfq-jv58 lists affected ranges: npm openclaw >=0 <2026.2.14)
- Verified: https://osv.dev/vulnerability/GHSA-gv46-4xfq-jv58 (OSV record GHSA-gv46-4xfq-jv58 lists affected ranges: npm openclaw >=0 <2026.2.14 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…