OpenClaw optional voice-call plugin: webhook verification may be bypassed behind certain proxy configurations
CVE-2026-28465GHSA-3m3q-x3gj-f79x
What to do
Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm @clawdbot/voice-call
- Affected
- <= 2026.1.24
- Fixed in
- no fixed version recorded
npm @openclaw/voice-call
- Affected
- < 2026.2.3
- Fixed in
- 2026.2.3
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-3m3q-x3gj-f79x lists affected ranges: npm @openclaw/voice-call >=0 =0 <=2026.1.24
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-3m3q-x3gj-f79x lists affected ranges: npm @openclaw/voice-call >=0 =0 <=2026.1.24
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 8.2 · CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2026-28465: 0.43% estimated exploitation activity in the next 30 days; percentile 37.77 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Affected Packages / Versions This issue affects the optional voice-call plugin only. It is not enabled by default; it only applies to installations where the plugin is installed and enabled. - Package: @openclaw/voice-call - Vulnerable versions: < 2026.2.3 - Patched versions: = 2026.2.3 Legacy package name (if you are still using it): - Package: @clawdbot/voice-call - Vulnerable versions: <= 2026.1.24 - Patched versions: none published under this package name; migrate to @openclaw/voice-call Summary In certain reverse-proxy / forwarding setups, webhook verification can be bypassed if untrusted forwarded headers are accepted. Impact An external party may be able to send voice-call webhook requests that are accepted as valid, which can result in spoofed webhook events being processed. Root Cause Some deployments implicitly trusted forwarded headers (for example Forwarded / X-Forwarded-) when determining request properties used during webhook verification. If those headers are not…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-3m3q-x3gj-f79x
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-3m3q-x3gj-f79x
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-28465 Advisory: OpenClaw optional voice-call plugin: webhook verification may be bypassed behind certain proxy configurations IDs: CVE-2026-28465, GHSA-3m3q-x3gj-f79x Record: https://patchnext.com/advisories/cve-2026-28465 (revision 3, source checked 26 Oct 2026, 12:43 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.2) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Partial vendor fix; fixed versions by package: @openclaw/voice-call 2026.2.3. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @clawdbot/voice-call: affected <= 2026.1.24 - npm @openclaw/voice-call: affected < 2026.2.3; fixed in 2026.2.3 ## Suggested inspection (read-only) - `npm ls @clawdbot/voice-call --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. - `npm ls @openclaw/voice-call --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @clawdbot/voice-call, @openclaw/voice-call. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-3m3q-x3gj-f79x (OSV record GHSA-3m3q-x3gj-f79x lists affected ranges: npm @openclaw/voice-call >=0 =0 <=2026.1.24) - Verified: https://github.com/advisories/GHSA-3m3q-x3gj-f79x (GitHub-reviewed advisory GHSA-3m3q-x3gj-f79x lists affected ranges: npm @openclaw/voice-call >=0 =0 <=2026.1.24) Commands are suggestions: review each one before running it.
Loading voting…