Skip to content

← Actionable
High, CVSS 8.6amended

OpenClaw exec approvals: safeBins could bypass stdin-only constraints via shell expansion

CVE-2026-28463GHSA-xvhf-x56f-2hpp

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (openclaw 2026.2.14), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm openclaw

    Affected
    < 2026.2.14
    Fixed in
    2026.2.14

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.6 · CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-28463: 0.19% estimated exploitation activity in the next 30 days; percentile 9.19 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary OpenClaw's exec-approvals allowlist supports a small set of "safe bins" intended to be stdin-only (no positional file arguments) when running tools.exec.host=gateway|node with security=allowlist. In affected configurations, the allowlist validation checked pre-expansion argv tokens, but execution used a real shell (sh -c) which expands globs and environment variables. This allowed safe bins like head, tail, or grep to read arbitrary local files via tokens such as or $HOME/... without triggering approvals. This issue is configuration-dependent and is not exercised by default settings (default tools.exec.host is sandbox). Affected Packages / Versions - Package: openclaw (npm) - Affected: <= 2026.2.13 - Patched: = 2026.2.14 (planned; publish the advisory after the npm release is out) Impact An authorized but untrusted caller (or prompt-injection) could cause the gateway/node process to disclose files readable by that process when host execution is enabled in allowlist mode. Fix…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-xvhf-x56f-2hpp

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-xvhf-x56f-2hpp

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-28463

Advisory: OpenClaw exec approvals: safeBins could bypass stdin-only constraints via shell expansion
IDs: CVE-2026-28463, GHSA-xvhf-x56f-2hpp
Record: https://patchnext.com/advisories/cve-2026-28463 (revision 3, source checked 26 Oct 2026, 12:43 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.6)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: openclaw 2026.2.14. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm openclaw: affected < 2026.2.14; fixed in 2026.2.14

## Suggested inspection (read-only)
- `npm ls openclaw --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on openclaw.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-xvhf-x56f-2hpp (OSV record GHSA-xvhf-x56f-2hpp lists affected ranges: npm openclaw >=0 <2026.2.14 (fixed))
- Verified: https://github.com/advisories/GHSA-xvhf-x56f-2hpp (GitHub-reviewed advisory GHSA-xvhf-x56f-2hpp lists affected ranges: npm openclaw >=0 <2026.2.14)

Commands are suggestions: review each one before running it.

Loading voting…