OpenClaw's sandbox skill mirroring path traversal vulnerability could write outside the sandbox workspace
CVE-2026-28457GHSA-xw4p-pw82-hqr7
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (openclaw 2026.2.14), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm openclaw
- Affected
- < 2026.2.14
- Fixed in
- 2026.2.14
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-xw4p-pw82-hqr7 lists affected ranges: npm openclaw >=0 <2026.2.14 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 5.6 · CVSS:4.0/AV:L/AC:L/AT:P/PR:N/UI:A/VC:N/VI:H/VA:L/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2026-28457: 0.16% estimated exploitation activity in the next 30 days; percentile 5.09 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Overview In affected versions, OpenClaw’s sandbox skill mirroring used the skill’s frontmatter `name` as part of the destination path when copying skills into the sandbox workspace. A crafted skill name containing traversal segments (for example `../`) or an absolute path could cause the copy to write outside ` /skills/`.
Impact - Files may be written outside the sandbox workspace root (within the permissions of the user running OpenClaw).
Attack Requirements - Attacker can provide a skill package (controls `SKILL.md` frontmatter). - Victim runs with sandbox enabled and skill mirroring into the sandbox workspace.
Affected Packages / Versions - `openclaw` (npm): ` = 2026.2.14`
Fix Commit(s) - 3eb6a31b6fcf8268456988bfa8e3637d373438c2 OpenClaw thanks @1seal for reporting.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-xw4p-pw82-hqr7
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-28457 Advisory: OpenClaw's sandbox skill mirroring path traversal vulnerability could write outside the sandbox workspace IDs: CVE-2026-28457, GHSA-xw4p-pw82-hqr7 Record: https://patchnext.com/advisories/cve-2026-28457 (revision 2, source checked 25 Oct 2026, 00:30 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.6) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: openclaw 2026.2.14. A vendor fix does not mean a deployment is fixed. ## Affected components - npm openclaw: affected < 2026.2.14; fixed in 2026.2.14 ## Suggested inspection (read-only) - `npm ls openclaw --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on openclaw. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-xw4p-pw82-hqr7 (OSV record GHSA-xw4p-pw82-hqr7 lists affected ranges: npm openclaw >=0 <2026.2.14 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…