OpenClaw affected by potential code execution via unsafe hook module path handling in Gateway
CVE-2026-28456GHSA-v6c6-vqqg-w888
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (openclaw 2026.2.14), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm openclaw
- Affected
- >= 2026.1.5, < 2026.2.14
- Fixed in
- 2026.2.14
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-v6c6-vqqg-w888 lists affected ranges: npm openclaw >=2026.1.5 <2026.2.14 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-v6c6-vqqg-w888 lists affected ranges: npm openclaw >=2026.1.5 <2026.2.14
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 8.6 · CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2026-28456: 0.47% estimated exploitation activity in the next 30 days; percentile 40.70 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary OpenClaw Gateway supports hook mappings with optional JavaScript/TypeScript transform modules. In affected versions, the gateway did not sufficiently constrain configured module paths before passing them to dynamic import(). Under some configurations, a user who can modify gateway configuration could cause the gateway process to load and execute an unintended local module. Impact Potential code execution in the OpenClaw gateway Node.js process. This requires access that can modify gateway configuration (for example via the gateway config endpoints). Treat such access as high privilege. Affected Packages / Versions - npm package: openclaw - Affected: = 2026.1.5 and <= 2026.2.13 Patched Versions - = 2026.2.14 Fix Commit(s) - a0361b8ba959e8506dc79d638b6e6a00d12887e4 (restrict hook transform module loading) - 35c0e66ed057f1a9f7ad2515fdcef516bd6584ce (harden hooks module loading) Mitigation - Upgrade to 2026.2.14 or newer. - Avoid exposing gateway configuration endpoints to…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-v6c6-vqqg-w888
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-v6c6-vqqg-w888
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-28456 Advisory: OpenClaw affected by potential code execution via unsafe hook module path handling in Gateway IDs: CVE-2026-28456, GHSA-v6c6-vqqg-w888 Record: https://patchnext.com/advisories/cve-2026-28456 (revision 3, source checked 26 Oct 2026, 12:43 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.6) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: openclaw 2026.2.14. A vendor fix does not mean a deployment is fixed. ## Affected components - npm openclaw: affected >= 2026.1.5, < 2026.2.14; fixed in 2026.2.14 ## Suggested inspection (read-only) - `npm ls openclaw --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on openclaw. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-v6c6-vqqg-w888 (OSV record GHSA-v6c6-vqqg-w888 lists affected ranges: npm openclaw >=2026.1.5 <2026.2.14 (fixed)) - Verified: https://github.com/advisories/GHSA-v6c6-vqqg-w888 (GitHub-reviewed advisory GHSA-v6c6-vqqg-w888 lists affected ranges: npm openclaw >=2026.1.5 <2026.2.14) Commands are suggestions: review each one before running it.
Loading voting…