Skip to content

← Actionable
Medium, CVSS 6.3amended

OpenClaw's unauthenticated Nostr profile HTTP endpoints allow remote profile/config tampering

CVE-2026-28450GHSA-mv9j-6xhh-g383

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (openclaw 2026.2.12), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm openclaw

    Affected
    < 2026.2.12
    Fixed in
    2026.2.12

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
6.3 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-28450: 0.40% estimated exploitation activity in the next 30 days; percentile 33.73 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary The OpenClaw Nostr channel plugin (optional, disabled by default, installed separately) exposes profile management HTTP endpoints under /api/channels/nostr/:accountId/profile (GET/PUT) and /api/channels/nostr/:accountId/profile/import (POST). In affected versions, these routes were dispatched via the gateway plugin HTTP layer without requiring gateway authentication, allowing unauthenticated remote callers to read or mutate the Nostr profile and persist changes to the gateway config. Profile updates are also published as a signed Nostr kind:0 event using the bot's private key. Deployments that do not have the Nostr plugin installed and enabled are not impacted. Affected Packages / Versions - Package: openclaw (npm) - Affected versions: <= 2026.2.9 - Fixed versions: = 2026.2.12 - Scope note: only affects deployments with the optional @openclaw/nostr plugin installed and enabled Details This is exploitable when the gateway HTTP port is reachable beyond localhost (for example:…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-mv9j-6xhh-g383

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-mv9j-6xhh-g383

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-28450

Advisory: OpenClaw's unauthenticated Nostr profile HTTP endpoints allow remote profile/config tampering
IDs: CVE-2026-28450, GHSA-mv9j-6xhh-g383
Record: https://patchnext.com/advisories/cve-2026-28450 (revision 3, source checked 26 Oct 2026, 12:43 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: openclaw 2026.2.12. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm openclaw: affected < 2026.2.12; fixed in 2026.2.12

## Suggested inspection (read-only)
- `npm ls openclaw --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on openclaw.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-mv9j-6xhh-g383 (OSV record GHSA-mv9j-6xhh-g383 lists affected ranges: npm openclaw >=0 <2026.2.12 (fixed))
- Verified: https://github.com/advisories/GHSA-mv9j-6xhh-g383 (GitHub-reviewed advisory GHSA-mv9j-6xhh-g383 lists affected ranges: npm openclaw >=0 <2026.2.12)

Commands are suggestions: review each one before running it.

Loading voting…