OpenClaw Twitch allowFrom is not enforced in optional plugin, unauthorized chat users can trigger agent pipeline
CVE-2026-28448GHSA-33rq-m5x2-fvgf
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (openclaw 2026.2.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm openclaw
- Affected
- >= 2026.1.29, < 2026.2.1
- Fixed in
- 2026.2.1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-33rq-m5x2-fvgf lists affected ranges: npm openclaw >=2026.1.29 <2026.2.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-33rq-m5x2-fvgf lists affected ranges: npm openclaw >=2026.1.29 <2026.2.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L
- EPSS
- CVE-2026-28448: 0.52% estimated exploitation activity in the next 30 days; percentile 43.93 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary In the optional Twitch channel plugin (extensions/twitch), allowFrom is documented as a hard allowlist of Twitch user IDs, but it was not enforced as a hard gate. If allowedRoles is unset or empty, the access control path defaulted to allow, so any Twitch user who could mention the bot could reach the agent dispatch pipeline. Scope note: This only affects deployments that installed and enabled the Twitch plugin. Core OpenClaw installs that do not install/enable the Twitch plugin are not impacted. Affected Packages / Versions - Package: openclaw (npm) - Affected: = 2026.1.29, < 2026.2.1 - Fixed: = 2026.2.1 Details Affected component: Twitch plugin access control (extensions/twitch/src/access-control.ts). Problematic logic in checkTwitchAccessControl(): - When allowFrom was configured, the code returned allowed: true for members but did not return allowed: false for non-members, so execution fell through. - If allowedRoles was unset or empty, the function returned allowed: true…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-33rq-m5x2-fvgf
- Revision 1 · created ·
Published from osv record GHSA-33rq-m5x2-fvgf
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-28448 Advisory: OpenClaw Twitch allowFrom is not enforced in optional plugin, unauthorized chat users can trigger agent pipeline IDs: CVE-2026-28448, GHSA-33rq-m5x2-fvgf Record: https://patchnext.com/advisories/cve-2026-28448 (revision 2, source checked 26 Oct 2026, 12:43 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: openclaw 2026.2.1. A vendor fix does not mean a deployment is fixed. ## Affected components - npm openclaw: affected >= 2026.1.29, < 2026.2.1; fixed in 2026.2.1 ## Suggested inspection (read-only) - `npm ls openclaw --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on openclaw. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-33rq-m5x2-fvgf (OSV record GHSA-33rq-m5x2-fvgf lists affected ranges: npm openclaw >=2026.1.29 <2026.2.1 (fixed)) - Verified: https://github.com/advisories/GHSA-33rq-m5x2-fvgf (GitHub-reviewed advisory GHSA-33rq-m5x2-fvgf lists affected ranges: npm openclaw >=2026.1.29 <2026.2.1) Commands are suggestions: review each one before running it.
Loading voting…