Skip to content

← Actionable
Critical, CVSS 9.2amended

OpenClaw has an inbound allowlist policy bypass in voice-call extension (empty caller ID + suffix matching)

CVE-2026-28446GHSA-4rj2-gpmh-qq5x

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (openclaw 2026.2.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm openclaw

    Affected
    < 2026.2.2
    Fixed in
    2026.2.2

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
9.2 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:L/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X · score source
EPSS
  • CVE-2026-28446: 0.75% estimated exploitation activity in the next 30 days; percentile 54.92 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary An authentication bypass in the optional voice-call extension/plugin allowed unapproved or anonymous callers to reach the voice-call agent when inbound policy was set to allowlist or pairing. Deployments that do not install/enable the voice-call extension are not affected. Affected Packages / Versions - openclaw (npm): <= 2026.2.1 - Fixed in: = 2026.2.2 Details In affected versions (for example 2026.2.1), the inbound allowlist check in extensions/voice-call/src/manager.ts used suffix-based matching and accepted empty caller IDs after normalization. This allowed two bypasses: 1. Missing/empty from values normalized to an empty string, which caused the allowlist predicate to evaluate as allowed. 2. Suffix-based matching meant any caller number whose digits ended with an allowlisted number would be accepted. Proof Of Concept 1. Configure the voice-call extension with inboundPolicy: allowlist and allowFrom: ["+15550001234"]. 2. Place/trigger an inbound call with missing/empty…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 4 · amended ·

    Amended from ghsa record GHSA-4rj2-gpmh-qq5x

  2. Revision 3 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 2 · amended ·

    Amended from osv record GHSA-4rj2-gpmh-qq5x

  4. Revision 1 · created ·

    Published from ghsa record GHSA-4rj2-gpmh-qq5x

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-28446

Advisory: OpenClaw has an inbound allowlist policy bypass in voice-call extension (empty caller ID + suffix matching)
IDs: CVE-2026-28446, GHSA-4rj2-gpmh-qq5x
Record: https://patchnext.com/advisories/cve-2026-28446 (revision 4, source checked 26 Oct 2026, 12:43 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.2)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: openclaw 2026.2.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm openclaw: affected < 2026.2.2; fixed in 2026.2.2

## Suggested inspection (read-only)
- `npm ls openclaw --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on openclaw.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-4rj2-gpmh-qq5x (GitHub-reviewed advisory GHSA-4rj2-gpmh-qq5x lists affected ranges: npm openclaw >=0 <2026.2.2)
- Verified: https://osv.dev/vulnerability/GHSA-4rj2-gpmh-qq5x (OSV record GHSA-4rj2-gpmh-qq5x lists affected ranges: npm openclaw >=0 <2026.2.2 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…