Statamic vulnerable to privilege escalation via stored cross-site scripting
CVE-2026-28426GHSA-5vrj-wf7v-5wr7
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (statamic/cms 6.4.0, 5.73.11), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist statamic/cms
- Affected
- < 5.73.11>= 6.0.0-alpha.1, < 6.4.0
- Fixed in
- 5.73.11, 6.4.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-5vrj-wf7v-5wr7 lists affected ranges: Packagist statamic/cms >=0 =6.0.0-alpha.1 <6.4.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.7 · CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:N
- EPSS
- CVE-2026-28426: 0.29% estimated exploitation activity in the next 30 days; percentile 22.02 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact Stored XSS vulnerability in svg and icon related components allow authenticated users with appropriate permissions to inject malicious JavaScript that executes when viewed by higher-privileged users. Patches This has been fixed in 5.73.11 and 6.4.0.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-5vrj-wf7v-5wr7
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-28426 Advisory: Statamic vulnerable to privilege escalation via stored cross-site scripting IDs: CVE-2026-28426, GHSA-5vrj-wf7v-5wr7 Record: https://patchnext.com/advisories/cve-2026-28426 (revision 1, source checked 26 Oct 2026, 14:38 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: statamic/cms 6.4.0, 5.73.11. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist statamic/cms: affected < 5.73.11; >= 6.0.0-alpha.1, < 6.4.0; fixed in 5.73.11, 6.4.0 ## Suggested inspection (read-only) - Packagist statamic/cms: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on statamic/cms. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-5vrj-wf7v-5wr7 (GitHub-reviewed advisory GHSA-5vrj-wf7v-5wr7 lists affected ranges: Packagist statamic/cms >=0 =6.0.0-alpha.1 <6.4.0) Commands are suggestions: review each one before running it.
Loading voting…