Statamic vulnerable to remote code execution via Antlers-enabled control panel inputs
CVE-2026-28425GHSA-cpv7-q2wx-m8rw
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (statamic/cms 6.7.2, 5.73.16), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist statamic/cms
- Affected
- < 5.73.16>= 6.0.0-alpha.1, < 6.7.2
- Fixed in
- 6.7.2, 5.73.16
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-cpv7-q2wx-m8rw lists affected ranges: Packagist statamic/cms >=0 =6.0.0-alpha.1 <6.7.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.0 · CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H
- EPSS
- CVE-2026-28425: 0.50% estimated exploitation activity in the next 30 days; percentile 42.86 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact An authenticated control panel user with access to Antlers-enabled inputs may be able to achieve remote code execution in the application context. That can lead to full compromise of the application, including access to sensitive configuration, modification or exfiltration of data, and potential impact on availability. Exploitation is only possible where Antlers runs on user-controlled content—for example, content fields with Antlers explicitly enabled (requiring permission to configure fields and to edit entries), built-in config that supports Antlers such as Forms email notification settings (requiring configuration permission), or third-party addons that add Antlers-enabled fields to entries (for example, the SEO Pro addon). In each case the attacker must have the relevant control panel permissions. Patches This has been fixed in 5.73.16 and 6.7.2. Note that a follow-up report showed that the original 5.73.11 & 6.4.0 fixes were insufficient. If you use addons that depend on…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-cpv7-q2wx-m8rw
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-28425 Advisory: Statamic vulnerable to remote code execution via Antlers-enabled control panel inputs IDs: CVE-2026-28425, GHSA-cpv7-q2wx-m8rw Record: https://patchnext.com/advisories/cve-2026-28425 (revision 1, source checked 26 Oct 2026, 14:39 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.0) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: statamic/cms 6.7.2, 5.73.16. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist statamic/cms: affected < 5.73.16; >= 6.0.0-alpha.1, < 6.7.2; fixed in 6.7.2, 5.73.16 ## Suggested inspection (read-only) - Packagist statamic/cms: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on statamic/cms. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-cpv7-q2wx-m8rw (GitHub-reviewed advisory GHSA-cpv7-q2wx-m8rw lists affected ranges: Packagist statamic/cms >=0 =6.0.0-alpha.1 <6.7.2) Commands are suggestions: review each one before running it.
Loading voting…