NocoDB Vulnerable to SQL Injection via DATEADD Formula
CVE-2026-28399GHSA-45rp-9p97-h852
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (nocodb 0.301.3), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm nocodb
- Affected
- <= 0.301.2
- Fixed in
- 0.301.3
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-45rp-9p97-h852 lists affected ranges: npm nocodb >=0 <0.301.3 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-45rp-9p97-h852 lists affected ranges: npm nocodb >=0 <=0.301.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 6.2 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N/E:U · score source
- EPSS
- CVE-2026-28399: 0.36% estimated exploitation activity in the next 30 days; percentile 30.14 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary An authenticated user with Creator role can inject arbitrary SQL via the DATEADD formula's unit parameter. Details The third argument (unit) of DATEADD was interpolated directly into knex.raw() queries after only stripping quote characters. Validation in formulas.ts only checked Literal AST node types — non-Literal types bypassed validation entirely. Affected MySQL, PostgreSQL, and SQLite function mappings. Impact SQL injection allowing data exfiltration or modification, scoped to the connected database. Credit This issue was reported by @q1uf3ng.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-45rp-9p97-h852
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-45rp-9p97-h852
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-28399 Advisory: NocoDB Vulnerable to SQL Injection via DATEADD Formula IDs: CVE-2026-28399, GHSA-45rp-9p97-h852 Record: https://patchnext.com/advisories/cve-2026-28399 (revision 3, source checked 26 Oct 2026, 12:42 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.2) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: nocodb 0.301.3. A vendor fix does not mean a deployment is fixed. ## Affected components - npm nocodb: affected <= 0.301.2; fixed in 0.301.3 ## Suggested inspection (read-only) - `npm ls nocodb --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on nocodb. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-45rp-9p97-h852 (OSV record GHSA-45rp-9p97-h852 lists affected ranges: npm nocodb >=0 <0.301.3 (fixed)) - Verified: https://github.com/advisories/GHSA-45rp-9p97-h852 (GitHub-reviewed advisory GHSA-45rp-9p97-h852 lists affected ranges: npm nocodb >=0 <=0.301.2) Commands are suggestions: review each one before running it.
Loading voting…