NocoDB Vulnerable to Stored Cross-Site Scripting via Comments and Rich Text Cells
CVE-2026-28398GHSA-8vm4-g489-v3w7
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (nocodb 0.301.3), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm nocodb
- Affected
- <= 0.301.2
- Fixed in
- 0.301.3
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-8vm4-g489-v3w7 lists affected ranges: npm nocodb >=0 <0.301.3 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-8vm4-g489-v3w7 lists affected ranges: npm nocodb >=0 <=0.301.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 5.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N · score source
- EPSS
- CVE-2026-28398: 0.17% estimated exploitation activity in the next 30 days; percentile 6.39 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary User-controlled content in comments and rich text cells was rendered via v-html without sanitization, enabling stored XSS. Details Comments in Comments.vue and rich text in TextArea.vue were parsed by markdown-it with html: true and injected via v-html. The codebase had vue-dompurify-html available but these paths used raw v-html. Server-side, Comment.insert() used extractProps() instead of extractPropsAndSanitize(). Commenter role is sufficient for the comments vector; Editor role for rich text. This issue was independently reported; see also GHSA-rcph-x7mj-54mm and GHSA-wwp2-x4rj-j8rm for the same root cause found by GitHub Security Lab. Impact Stored XSS — malicious scripts execute for any user viewing the comment or cell. Credit This issue was reported by @bugbunny-research (bugbunny.ai).
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-8vm4-g489-v3w7
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-8vm4-g489-v3w7
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-28398 Advisory: NocoDB Vulnerable to Stored Cross-Site Scripting via Comments and Rich Text Cells IDs: CVE-2026-28398, GHSA-8vm4-g489-v3w7 Record: https://patchnext.com/advisories/cve-2026-28398 (revision 3, source checked 26 Oct 2026, 12:42 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: nocodb 0.301.3. A vendor fix does not mean a deployment is fixed. ## Affected components - npm nocodb: affected <= 0.301.2; fixed in 0.301.3 ## Suggested inspection (read-only) - `npm ls nocodb --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on nocodb. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-8vm4-g489-v3w7 (OSV record GHSA-8vm4-g489-v3w7 lists affected ranges: npm nocodb >=0 <0.301.3 (fixed)) - Verified: https://github.com/advisories/GHSA-8vm4-g489-v3w7 (GitHub-reviewed advisory GHSA-8vm4-g489-v3w7 lists affected ranges: npm nocodb >=0 <=0.301.2) Commands are suggestions: review each one before running it.
Loading voting…