Skip to content

← Actionable
Medium, CVSS 5.3amended

NocoDB Vulnerable to Stored Cross-site Scripting via Comments

CVE-2026-28397GHSA-rcph-x7mj-54mm

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (nocodb 0.301.3), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm nocodb

    Affected
    <= 0.301.2
    Fixed in
    0.301.3

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
5.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N · score source
EPSS
  • CVE-2026-28397: 0.21% estimated exploitation activity in the next 30 days; percentile 10.72 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary Comments rendered via v-html without sanitization, enabling stored XSS. Details Comments in Comments.vue were parsed by markdown-it with html: true and injected via v-html without DOMPurify. A user with Commenter role can inject arbitrary HTML that executes for all viewers. Impact Stored XSS — malicious scripts execute for any user viewing the comment. Credit This issue was discovered by an AI agent developed by the GitHub Security Lab and reviewed by GHSL team members @p- (Peter Stockli) and @m-y-mo (Man Yue Mo).

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-rcph-x7mj-54mm

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-rcph-x7mj-54mm

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-28397

Advisory: NocoDB Vulnerable to Stored Cross-site Scripting via Comments
IDs: CVE-2026-28397, GHSA-rcph-x7mj-54mm
Record: https://patchnext.com/advisories/cve-2026-28397 (revision 3, source checked 26 Oct 2026, 12:42 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: nocodb 0.301.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm nocodb: affected <= 0.301.2; fixed in 0.301.3

## Suggested inspection (read-only)
- `npm ls nocodb --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on nocodb.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-rcph-x7mj-54mm (OSV record GHSA-rcph-x7mj-54mm lists affected ranges: npm nocodb >=0 <0.301.3 (fixed))
- Verified: https://github.com/advisories/GHSA-rcph-x7mj-54mm (GitHub-reviewed advisory GHSA-rcph-x7mj-54mm lists affected ranges: npm nocodb >=0 <=0.301.2)

Commands are suggestions: review each one before running it.

Loading voting…