Skip to content

← Actionable
Medium, CVSS 6.3amended

OpenClaw's Chrome extension relay binds publicly due to wildcard treated as loopback

CVE-2026-28395GHSA-qw99-grcx-4pvm

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (openclaw 2026.2.12), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm openclaw

    Affected
    >= 2026.1.14-1, < 2026.2.12
    Fixed in
    2026.2.12

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
6.3 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:L/VI:N/VA:L/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-28395: 0.46% estimated exploitation activity in the next 30 days; percentile 39.94 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary The Chrome extension relay (ensureChromeExtensionRelayServer) previously treated wildcard hosts (0.0.0.0 / ::) as loopback, which could make it bind the relay HTTP/WS server to all interfaces when a wildcard cdpUrl was passed. Impact If configured with a wildcard cdpUrl, relay HTTP endpoints could become reachable off-host, leaking service presence/port and enabling DoS/brute-force traffic against the relay token header. Affected Packages / Versions - Package: openclaw (npm) - Affected: = 2026.1.14-1 < 2026.2.12 Fixed Versions - Patched: = 2026.2.12 (released 2026-02-13) Fix Commit(s) - 8d75a496bf5aaab1755c56cf48502d967c75a1d0 Notes - Earlier hardening for /json auth and /cdp token checks landed in: - a1e89afcc19efd641c02b24d66d689f181ae2b5c Thanks @qi-scape for reporting.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-qw99-grcx-4pvm

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-qw99-grcx-4pvm

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-28395

Advisory: OpenClaw's Chrome extension relay binds publicly due to wildcard treated as loopback
IDs: CVE-2026-28395, GHSA-qw99-grcx-4pvm
Record: https://patchnext.com/advisories/cve-2026-28395 (revision 3, source checked 26 Oct 2026, 12:43 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: openclaw 2026.2.12. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm openclaw: affected >= 2026.1.14-1, < 2026.2.12; fixed in 2026.2.12

## Suggested inspection (read-only)
- `npm ls openclaw --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on openclaw.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-qw99-grcx-4pvm (OSV record GHSA-qw99-grcx-4pvm lists affected ranges: npm openclaw >=2026.1.14-1 <2026.2.12 (fixed))
- Verified: https://github.com/advisories/GHSA-qw99-grcx-4pvm (GitHub-reviewed advisory GHSA-qw99-grcx-4pvm lists affected ranges: npm openclaw >=2026.1.14-1 <2026.2.12)

Commands are suggestions: review each one before running it.

Loading voting…