PMD Designer has Stored XSS in VBHTMLRenderer and YAHTMLRenderer via unescaped violation messages
CVE-2026-28338GHSA-8rr6-2qw5-pc7r
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (net.sourceforge.pmd:pmd-core 7.22.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven net.sourceforge.pmd:pmd-core
- Affected
- <= 7.21.0
- Fixed in
- 7.22.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-8rr6-2qw5-pc7r lists affected ranges: Maven net.sourceforge.pmd:pmd-core >=0 <=7.21.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.8 · CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:N
- EPSS
- CVE-2026-28338: 0.35% estimated exploitation activity in the next 30 days; percentile 28.21 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary PMD's vbhtml and yahtml report formats insert rule violation messages into HTML output without escaping. When PMD analyzes untrusted source code containing crafted string literals, the generated HTML report contains executable JavaScript that runs when opened in a browser. While the default html format is not affected via rule violation messages (it correctly uses StringEscapeUtils.escapeHtml4()), it has a similar problem when rendering suppressed violations. The user supplied message (the reason for the suppression) was not escaped. Details VBHTMLRenderer.java line 71 appends rv.getDescription() directly into HTML: YAHTMLRenderer.java lines 196–203 does the same via renderViolationRow(): Called at line 172: The violation message originates from AvoidDuplicateLiteralsRule.java line 91, which embeds raw string literal values via first.toPrintableString(). This calls StringUtil.escapeJava() (line 476–480), which is a Java source escaper — it passes <, , and & through unchanged…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-8rr6-2qw5-pc7r
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-28338 Advisory: PMD Designer has Stored XSS in VBHTMLRenderer and YAHTMLRenderer via unescaped violation messages IDs: CVE-2026-28338, GHSA-8rr6-2qw5-pc7r Record: https://patchnext.com/advisories/cve-2026-28338 (revision 1, source checked 26 Oct 2026, 16:44 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: net.sourceforge.pmd:pmd-core 7.22.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven net.sourceforge.pmd:pmd-core: affected <= 7.21.0; fixed in 7.22.0 ## Suggested inspection (read-only) - Maven net.sourceforge.pmd:pmd-core: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on net.sourceforge.pmd:pmd-core. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-8rr6-2qw5-pc7r (GitHub-reviewed advisory GHSA-8rr6-2qw5-pc7r lists affected ranges: Maven net.sourceforge.pmd:pmd-core >=0 <=7.21.0) Commands are suggestions: review each one before running it.
Loading voting…