simple-git has blockUnsafeOperationsPlugin bypass via case-insensitive protocol.allow config key enables RCE
CVE-2026-28292GHSA-r275-fr43-pm7q
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (simple-git 3.32.3), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm simple-git
- Affected
- >= 3.15.0, < 3.32.3
- Fixed in
- 3.32.3
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-r275-fr43-pm7q lists affected ranges: npm simple-git >=3.15.0 <3.32.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-r275-fr43-pm7q lists affected ranges: npm simple-git >=3.15.0 <3.32.3 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2026-28292: 1.35% estimated exploitation activity in the next 30 days; percentile 71.50 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary The blockUnsafeOperationsPlugin in simple-git fails to block git protocol override arguments when the config key is passed in uppercase or mixed case. An attacker who controls arguments passed to git operations can enable the ext:: protocol by passing -c PROTOCOL.ALLOW=always, which executes an arbitrary OS command on the host machine. --- Details The preventProtocolOverride function in simple-git/src/lib/plugins/block-unsafe-operations-plugin.ts (line 24) checks whether a -c argument configures protocol.allow using this regex: This regex is case-sensitive. Git treats config key names case-insensitively — it normalises them to lowercase internally. As a result, passing PROTOCOL.ALLOW=always, Protocol.Allow=always, or any mixed-case variant is not matched by the regex, the check returns without throwing, and git is spawned with the unsafe argument. Verification that git normalises the key: The fix is a single character — add the /i flag: --- poc.js --- Test Results Vector 1 —…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-r275-fr43-pm7q
- Revision 2 · amended ·
Amended from osv record GHSA-r275-fr43-pm7q
- Revision 1 · created ·
Published from ghsa record GHSA-r275-fr43-pm7q
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-28292 Advisory: simple-git has blockUnsafeOperationsPlugin bypass via case-insensitive protocol.allow config key enables RCE IDs: CVE-2026-28292, GHSA-r275-fr43-pm7q Record: https://patchnext.com/advisories/cve-2026-28292 (revision 3, source checked 26 Oct 2026, 12:48 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: simple-git 3.32.3. A vendor fix does not mean a deployment is fixed. ## Affected components - npm simple-git: affected >= 3.15.0, < 3.32.3; fixed in 3.32.3 ## Suggested inspection (read-only) - `npm ls simple-git --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on simple-git. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-r275-fr43-pm7q (GitHub-reviewed advisory GHSA-r275-fr43-pm7q lists affected ranges: npm simple-git >=3.15.0 <3.32.3) - Verified: https://osv.dev/vulnerability/GHSA-r275-fr43-pm7q (OSV record GHSA-r275-fr43-pm7q lists affected ranges: npm simple-git >=3.15.0 <3.32.3 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…