simple-git Affected by Command Execution via Option-Parsing Bypass
CVE-2026-28291GHSA-jcxm-m3jx-f287
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (simple-git 3.32.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm simple-git
- Affected
- < 3.32.0
- Fixed in
- 3.32.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-jcxm-m3jx-f287 lists affected ranges: npm simple-git >=0 <3.32.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-jcxm-m3jx-f287 lists affected ranges: npm simple-git >=0 <3.32.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.1 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2026-28291: 0.77% estimated exploitation activity in the next 30 days; percentile 55.62 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary simple-git enables running native Git commands from JavaScript. Some commands accept options that allow executing another command; because this is very dangerous, execution is denied unless the user explicitly allows it. This vulnerability allows a malicious actor who can control the options to execute other commands even in a “safe” state where the user has not explicitly allowed them. The vulnerability was introduced by an incorrect patch for CVE-2022-25860. It is likely to affect all versions prior to and including 3.28.0. Detail This vulnerability was introduced by an incorrect patch for CVE-2022-25860. It was reproduced in the following environment: The issue was not reproduced on Windows 11. The -u option, like --upload-pack, allows a command to be executed. Currently, the -u and --upload-pack options are blocked in the file simple-git/src/lib/plugins/block-unsafe-operations-plugin.ts. However, the problem is that command option parsing is quite flexible. By brute…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-jcxm-m3jx-f287
- Revision 1 · created ·
Published from osv record GHSA-jcxm-m3jx-f287
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-28291 Advisory: simple-git Affected by Command Execution via Option-Parsing Bypass IDs: CVE-2026-28291, GHSA-jcxm-m3jx-f287 Record: https://patchnext.com/advisories/cve-2026-28291 (revision 2, source checked 26 Oct 2026, 12:48 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: simple-git 3.32.0. A vendor fix does not mean a deployment is fixed. ## Affected components - npm simple-git: affected < 3.32.0; fixed in 3.32.0 ## Suggested inspection (read-only) - `npm ls simple-git --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on simple-git. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-jcxm-m3jx-f287 (OSV record GHSA-jcxm-m3jx-f287 lists affected ranges: npm simple-git >=0 <3.32.0 (fixed)) - Verified: https://github.com/advisories/GHSA-jcxm-m3jx-f287 (GitHub-reviewed advisory GHSA-jcxm-m3jx-f287 lists affected ranges: npm simple-git >=0 <3.32.0) Commands are suggestions: review each one before running it.
Loading voting…