Skip to content

← Actionable
Medium, CVSS 6.1

osctrl has Stored Cross-Site Scripting (XSS) in On-Demand Query List

CVE-2026-28280GHSA-4rv8-5cmm-2r22

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/jmpsec/osctrl 0.5.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.1 · CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:U/C:H/I:H/A:N
EPSS
  • CVE-2026-28280: 0.27% estimated exploitation activity in the next 30 days; percentile 19.36 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary A stored Cross-site Scripting (XSS) vulnerability exists in the osctrl-admin on-demand query list. A user with query-level permissions can inject arbitrary JavaScript via the query parameter when running an on-demand query. The payload is stored and executes in the browser of any user (including administrators) who visits the query list page. This can be chained with CSRF token extraction to escalate privileges and take actions as the logged in user. Impact An attacker with query-level permissions (the lowest privilege tier) can execute arbitrary JavaScript in the browsers of all users who view the query list. Depending on their level of access, it can lead to full platform compromise if an administrator executes the payload. Patches Fixed in osctrl v0.5.0. Users should upgrade immediately. Workarounds Restrict query-level permissions to trusted users. Monitor query list for suspicious payloads. Review osctrl user accounts for unauthorized administrators. References -…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-4rv8-5cmm-2r22

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-28280

Advisory: osctrl has Stored Cross-Site Scripting (XSS) in On-Demand Query List
IDs: CVE-2026-28280, GHSA-4rv8-5cmm-2r22
Record: https://patchnext.com/advisories/cve-2026-28280 (revision 1, source checked 26 Oct 2026, 15:15 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: github.com/jmpsec/osctrl 0.5.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/jmpsec/osctrl: affected < 0.5.0; fixed in 0.5.0

## Suggested inspection (read-only)
- Go github.com/jmpsec/osctrl: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/jmpsec/osctrl.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-4rv8-5cmm-2r22 (GitHub-reviewed advisory GHSA-4rv8-5cmm-2r22 lists affected ranges: Go github.com/jmpsec/osctrl >=0 <0.5.0)

Commands are suggestions: review each one before running it.

Loading voting…