Skip to content

← Actionable
Medium, CVSS 6.8amended

LangGraph checkpoint loading has unsafe msgpack deserialization

CVE-2026-28277GHSA-g48c-2wqr-h844

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (langgraph 1.0.10), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.8 · CVSS:3.1/AV:A/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2026-28277: 5.49% estimated exploitation activity in the next 30 days; percentile 92.79 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

LangGraph checkpointers can load msgpack-encoded checkpoints that reconstruct Python objects during deserialization. If an attacker can modify checkpoint data in the backing store (for example, after a database compromise or other privileged write access to the persistence layer), they can potentially supply a crafted payload that triggers unsafe object reconstruction when the checkpoint is loaded. This is a post-exploitation / defense-in-depth issue. Exploitation requires the ability to write attacker-controlled checkpoint bytes at rest. In most deployments that prerequisite already implies a serious incident; the additional risk is turning “checkpoint-store write access” into code execution in the application runtime, which can expand blast radius (for example by exposing environment variables or cloud credentials available to the runtime). There is no evidence of exploitation in the wild, and LangGraph is not aware of a practical exploitation path in existing deployments today.…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-g48c-2wqr-h844

  2. Revision 1 · created ·

    Published from osv record GHSA-g48c-2wqr-h844

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-28277

Advisory: LangGraph checkpoint loading has unsafe msgpack deserialization
IDs: CVE-2026-28277, GHSA-g48c-2wqr-h844
Record: https://patchnext.com/advisories/cve-2026-28277 (revision 2, source checked 26 Oct 2026, 13:44 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: langgraph 1.0.10. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI langgraph: affected <= 1.0.9; fixed in 1.0.10

## Suggested inspection (read-only)
- `python -m pip show langgraph`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on langgraph.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-g48c-2wqr-h844 (OSV record GHSA-g48c-2wqr-h844 lists affected ranges: PyPI langgraph >=0 <1.0.10 (fixed))
- Verified: https://github.com/advisories/GHSA-g48c-2wqr-h844 (GitHub-reviewed advisory GHSA-g48c-2wqr-h844 lists affected ranges: PyPI langgraph >=0 <=1.0.9)

Commands are suggestions: review each one before running it.

Loading voting…