Skip to content

← Actionable
Medium, CVSS 5.5amended

pillow-heif: Integer Overflow in Encode Path Buffer Validation Leads to Heap Out-of-Bounds Read

CVE-2026-28231GHSA-5gjj-6r7v-ph3x

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (pi-heif 1.3.0; pillow-heif 1.3.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
5.5 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N/E:P · score source
EPSS
  • CVE-2026-28231: 0.70% estimated exploitation activity in the next 30 days; percentile 53.33 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary An integer overflow in the encode path buffer validation of pillowheif.c allows an attacker to bypass bounds checks by providing large image dimensions, resulting in a heap out-of-bounds read. This can lead to information disclosure (server heap memory leaking into encoded images) or denial of service (process crash). No special configuration is required — this triggers under default settings. Details The buffer validation in CtxWriteImageaddplane(), CtxWriteImageaddplanela(), and CtxWriteImageaddplanel() uses 32-bit int multiplication to check whether the input buffer is large enough: Both stridein and height are declared as int (32-bit signed). When their product exceeds INTMAX (2,147,483,647), the multiplication overflows before the comparison with buffer.len (which is Pyssizet, 64-bit). The overflowed value wraps to zero or a negative number, causing the bounds check to pass incorrectly. For example, with stridein = 196608 (65536 × 3 for RGB) and height = 65536: - True…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-5gjj-6r7v-ph3x

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-5gjj-6r7v-ph3x

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-28231

Advisory: pillow-heif: Integer Overflow in Encode Path Buffer Validation Leads to Heap Out-of-Bounds Read
IDs: CVE-2026-28231, GHSA-5gjj-6r7v-ph3x
Record: https://patchnext.com/advisories/cve-2026-28231 (revision 3, source checked 26 Oct 2026, 13:49 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: pi-heif 1.3.0; pillow-heif 1.3.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI pi-heif: affected < 1.3.0; fixed in 1.3.0
- PyPI pillow-heif: affected < 1.3.0; fixed in 1.3.0

## Suggested inspection (read-only)
- `python -m pip show pi-heif`: prints the installed version. Run with the environment that serves production active.
- `python -m pip show pillow-heif`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on pi-heif, pillow-heif.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-5gjj-6r7v-ph3x (OSV record GHSA-5gjj-6r7v-ph3x lists affected ranges: PyPI pi-heif >=0 =0 <1.3.0 (fixed))
- Verified: https://github.com/advisories/GHSA-5gjj-6r7v-ph3x (GitHub-reviewed advisory GHSA-5gjj-6r7v-ph3x lists affected ranges: PyPI pi-heif >=0 =0 <1.3.0)

Commands are suggestions: review each one before running it.

Loading voting…