Wagtail Vulnerable to Cross-site Scripting in TableBlock class attributes
CVE-2026-28222GHSA-p5cm-246w-84jm
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (wagtail 7.3.1, 7.2.3, 7.0.6, 6.3.8), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI wagtail
- Affected
- < 6.3.8>= 6.4rc1, < 7.0.6>= 7.1rc1, < 7.2.3>= 7.3rc1, < 7.3.1
- Fixed in
- 6.3.8, 7.2.3, 7.3.1, 7.0.6
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-p5cm-246w-84jm lists affected ranges: PyPI wagtail >=0 =6.4rc1 =7.1rc1 =7.3rc1 <7.3.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-p5cm-246w-84jm lists affected ranges: PyPI wagtail >=0 =6.4rc1 =7.1rc1 =7.3rc1 <7.3.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.1 · CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:U/C:H/I:H/A:N
- EPSS
- CVE-2026-28222: 0.50% estimated exploitation activity in the next 30 days; percentile 43.08 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact A stored Cross-site Scripting (XSS) vulnerability exists on rendering TableBlock blocks within a StreamField. A user with access to create or edit pages containing TableBlock StreamField blocks is able to set specially-crafted class attributes on the block which run arbitrary JavaScript code when the page is viewed. When viewed by a user with higher privileges, this could lead to performing actions with that user's credentials. The vulnerability is not exploitable by an ordinary site visitor without access to the Wagtail admin, and only affects sites using TableBlock. Patches Patched versions have been released as Wagtail 6.3.8, 7.0.6, 7.2.3 and 7.3.1. Workarounds Site owners who are unable to upgrade to the new versions can remediate the vulnerability by setting a template attribute on all TableBlock definitions, referencing a template that does not output class attributes. For example: Acknowledgements Many thanks to Guan Chenxian (@GCXWLP) for reporting this issue. For more…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-p5cm-246w-84jm
- Revision 1 · created ·
Published from osv record GHSA-p5cm-246w-84jm
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-28222 Advisory: Wagtail Vulnerable to Cross-site Scripting in TableBlock class attributes IDs: CVE-2026-28222, GHSA-p5cm-246w-84jm Record: https://patchnext.com/advisories/cve-2026-28222 (revision 2, source checked 26 Oct 2026, 13:49 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: wagtail 7.3.1, 7.2.3, 7.0.6, 6.3.8. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI wagtail: affected < 6.3.8; >= 6.4rc1, < 7.0.6; >= 7.1rc1, < 7.2.3; >= 7.3rc1, < 7.3.1; fixed in 6.3.8, 7.2.3, 7.3.1, 7.0.6 ## Suggested inspection (read-only) - `python -m pip show wagtail`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on wagtail. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-p5cm-246w-84jm (OSV record GHSA-p5cm-246w-84jm lists affected ranges: PyPI wagtail >=0 =6.4rc1 =7.1rc1 =7.3rc1 <7.3.1 (fixed)) - Verified: https://github.com/advisories/GHSA-p5cm-246w-84jm (GitHub-reviewed advisory GHSA-p5cm-246w-84jm lists affected ranges: PyPI wagtail >=0 =6.4rc1 =7.1rc1 =7.3rc1 <7.3.1) Commands are suggestions: review each one before running it.
Loading voting…