Skip to content

← Actionable
Medium, CVSS 6.9amended

Next.js: Unbounded next/image disk cache growth can exhaust storage

CVE-2026-27980GHSA-3x4c-7xq6-9pq8

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (next 16.1.7, 15.5.14), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm next

    Affected
    >= 16.0.0-beta.0, < 16.1.7>= 10.0.0, < 15.5.14
    Fixed in
    15.5.14, 16.1.7

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
6.9 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-27980: 0.71% estimated exploitation activity in the next 30 days; percentile 53.56 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary The default Next.js image optimization disk cache (/next/image) did not have a configurable upper bound, allowing unbounded cache growth. Impact An attacker could generate many unique image-optimization variants and exhaust disk space, causing denial of service. Note that this does not impact platforms that have their own image optimization capabilities, such as Vercel. Patches Fixed by adding an LRU-backed disk cache with images.maximumDiskCacheSize, including eviction of least-recently-used entries when the limit is exceeded. Setting maximumDiskCacheSize: 0 disables disk caching. Workarounds If upgrade is not immediately possible: - Periodically clean .next/cache/images. - Reduce variant cardinality (e.g., tighten values for images.localPatterns, images.remotePatterns, and images.qualities)

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-3x4c-7xq6-9pq8

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-3x4c-7xq6-9pq8

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-27980

Advisory: Next.js: Unbounded next/image disk cache growth can exhaust storage
IDs: CVE-2026-27980, GHSA-3x4c-7xq6-9pq8
Record: https://patchnext.com/advisories/cve-2026-27980 (revision 3, source checked 26 Oct 2026, 12:46 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: next 16.1.7, 15.5.14. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm next: affected >= 16.0.0-beta.0, < 16.1.7; >= 10.0.0, < 15.5.14; fixed in 15.5.14, 16.1.7

## Suggested inspection (read-only)
- `npm ls next --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on next.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-3x4c-7xq6-9pq8 (OSV record GHSA-3x4c-7xq6-9pq8 lists affected ranges: npm next >=16.0.0-beta.0 =10.0.0 <15.5.14 (fixed))
- Verified: https://github.com/advisories/GHSA-3x4c-7xq6-9pq8 (GitHub-reviewed advisory GHSA-3x4c-7xq6-9pq8 lists affected ranges: npm next >=16.0.0-beta.0 =10.0.0 <15.5.14)

Commands are suggestions: review each one before running it.

Loading voting…