Skip to content

← Actionable
Medium, CVSS 6.9amended

Next.js: Unbounded postponed resume buffering can lead to DoS

CVE-2026-27979GHSA-h27x-g6w4-24gq

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (next 16.1.7), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm next

    Affected
    >= 16.0.1, < 16.1.7
    Fixed in
    16.1.7

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
6.9 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-27979: 0.69% estimated exploitation activity in the next 30 days; percentile 52.96 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary A request containing the next-resume: 1 header (corresponding with a PPR resume request) would buffer request bodies without consistently enforcing maxPostponedStateSize in certain setups. The previous mitigation protected minimal-mode deployments, but equivalent non-minimal deployments remained vulnerable to the same unbounded postponed resume-body buffering behavior. Impact In applications using the App Router with Partial Prerendering capability enabled (via experimental.ppr or cacheComponents), an attacker could send oversized next-resume POST payloads that were buffered without consistent size enforcement in non-minimal deployments, causing excessive memory usage and potential denial of service. Patches Fixed by enforcing size limits across all postponed-body buffering paths and erroring when limits are exceeded. Workarounds If upgrade is not immediately possible: - Block requests containing the next-resume header, as this is never valid to be sent from an untrusted…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-h27x-g6w4-24gq

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-h27x-g6w4-24gq

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-27979

Advisory: Next.js: Unbounded postponed resume buffering can lead to DoS
IDs: CVE-2026-27979, GHSA-h27x-g6w4-24gq
Record: https://patchnext.com/advisories/cve-2026-27979 (revision 3, source checked 26 Oct 2026, 12:46 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: next 16.1.7. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm next: affected >= 16.0.1, < 16.1.7; fixed in 16.1.7

## Suggested inspection (read-only)
- `npm ls next --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on next.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-h27x-g6w4-24gq (OSV record GHSA-h27x-g6w4-24gq lists affected ranges: npm next >=16.0.1 <16.1.7 (fixed))
- Verified: https://github.com/advisories/GHSA-h27x-g6w4-24gq (GitHub-reviewed advisory GHSA-h27x-g6w4-24gq lists affected ranges: npm next >=16.0.1 <16.1.7)

Commands are suggestions: review each one before running it.

Loading voting…